summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-04 22:10:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-04 22:21:33 +0300
commitb82c63d013758fe0e0416b9ff36cb2de18cafa1e (patch)
tree745ef08298b3f73536241b9c7273ef287bf0edfa /gnu/packages/irc.scm
parent4b1dd9ab3130d8e0f2398564a4e3667d8a3238a2 (diff)
downloadguix-patches-b82c63d013758fe0e0416b9ff36cb2de18cafa1e.tar
guix-patches-b82c63d013758fe0e0416b9ff36cb2de18cafa1e.tar.gz
gnu: quassel: Update package definition.
* gnu/packages/irc.scm (quassel)[source]: Remove bundled scripts. [arguments]: Update comments in 'configure-flags. [inputs]: Remove oxygen-icons. Move extra-cmake-modules and qttools ... [native-inputs]: ... to here.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm29
1 files changed, 18 insertions, 11 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index cdbdc44e68..4545a88948 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -69,26 +69,33 @@
(patches (search-patches "quassel-fix-tls-check.patch"))
(sha256
(base32
- "0ka456fb8ha3w7g74xlzfg6w4azxjjxgrhl4aqpbwg3lnd6fbr4k"))))
+ "0ka456fb8ha3w7g74xlzfg6w4azxjjxgrhl4aqpbwg3lnd6fbr4k"))
+ (modules '((guix build utils)))
+ ;; We don't want to install the bundles scripts
+ (snippet
+ '(begin
+ (delete-file-recursively "data/scripts")
+ (substitute* "data/CMakeLists.txt"
+ (("NOT WIN32") "WIN32"))))))
(build-system cmake-build-system)
(arguments
;; The three binaries are not mutually exlusive, and are all built
;; by default.
- `(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 5.0 MiB
- ;;"-DWANT_CORE=OFF" ; 2.3 MiB
- ;;"-DWANT_MONO=OFF" ; 6.3 MiB
+ '(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 5.2 MiB
+ ;;"-DWANT_CORE=OFF" ; 2.4 MiB
+ ;;"-DWANT_MONO=OFF" ; 6.4 MiB
"-DUSE_QT5=ON" ; default is qt4
- "-DWITH_KDE=OFF" ; no to integration
- "-DWITH_OXYGEN=ON" ; on=embed icons
+ "-DWITH_KDE=OFF" ; no to kde integration ...
+ "-DWITH_OXYGEN=ON" ; therefore we install bundled icons
"-DWITH_WEBKIT=OFF") ; qtwebkit isn't packaged
#:tests? #f)) ; no test target
- (native-inputs `(("pkg-config" ,pkg-config)))
- (inputs
+ (native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
- ("oxygen-icons" ,oxygen-icons)
- ("qca" ,qca)
+ ("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("qca" ,qca)
("qtbase", qtbase)
- ("qttools" ,qttools)
("qtscript" ,qtscript)
("snorenotify" ,snorenotify)
("zlib" ,zlib)))