summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/irc.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm52
1 files changed, 48 insertions, 4 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 470c7ec8f3..f6e95bc14e 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -47,6 +47,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages backup)
#:use-module (gnu packages check)
+ #:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
@@ -190,14 +191,14 @@ SILC and ICB protocols via plugins.")
(define-public weechat
(package
(name "weechat")
- (version "3.2")
+ (version "3.3")
(source (origin
(method url-fetch)
(uri (string-append "https://weechat.org/files/src/weechat-"
version ".tar.xz"))
(sha256
(base32
- "1a47knznlm9f2f83d71s3c4fm50m6iq6iq1bvp4m61p8fkrsva1r"))))
+ "1pyb1yaw61cbdg1g4cc22px1wsh8wm0gsx1yzp684idyz25apzna"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -242,7 +243,7 @@ using a mouse. It is customizable and extensible with plugins and scripts.")
(define-public srain
(package
(name "srain")
- (version "1.2.3")
+ (version "1.3.0")
(source
(origin
(method git-fetch)
@@ -251,7 +252,7 @@ using a mouse. It is customizable and extensible with plugins and scripts.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0rlpygcpacgcfjxw3brw99ad3rc7zs96p5c6rg6j79p6sy38lrfs"))))
+ (base32 "14s0h5wgvlkdylnjis2fa7m835142jzw0d0yqjnir1wqnwmq1rld"))))
(build-system meson-build-system)
(arguments
`(#:tests? #f ;there are no tests
@@ -325,6 +326,49 @@ for the IRCv3 protocol.")
"ircII is a terminal based IRC and ICB client for UNIX systems.")
(license license:bsd-3)))
+(define-public catgirl
+ (package
+ (name "catgirl")
+ (version "1.9a")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://git.causal.agency/catgirl/snapshot/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pci8crcgm33zb58y7ky2aydzyqsirj8ri8ik1zdlz6npadbjj9h"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags (list (string-append "PREFIX=" %output)
+ ,(string-append "CC=" (cc-for-target)))))
+ (native-inputs
+ `(("universal-ctags" ,universal-ctags)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libressl" ,libressl)
+ ("ncurses" ,ncurses)))
+ (home-page "https://git.causal.agency/catgirl")
+ (synopsis "TLS-only terminal IRC client")
+ (description
+ "@command{catgirl} is a TLS-only terminal IRC client.
+
+Notable features include:
+@itemize
+@item Tab complete: most recently seen or mentioned nicks are completed first.
+ Commas are inserted between multiple nicks.
+@item Prompt: the prompt clearly shows whether input will be interpreted as a
+command or sent as a message.
+@item Split scroll: keeps the latest messages in view while scrolling.
+@item URL detection: recent URLs from a particular user or matching a
+substring can be opened or copied.
+@item Nick coloring: color generation based on usernames remains stable across
+nick changes. Mentions of users in messages are colored.
+@item Topic diffing: the modified portion of a channel topic change is
+highlighted.
+@end itemize")
+ (license license:gpl3+)))
+
(define-public ii
(package
(name "ii")