summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-16 21:18:59 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-16 23:36:27 +0200
commit87257e6d371d80ddba254ef6f3123128385ff7fd (patch)
tree2ad30f2c0a532fec815ca563f63647ed00054bc3 /gnu/packages/irc.scm
parent6a513960c4784f12b0a1ae818cae00ddef4910b1 (diff)
downloadguix-patches-87257e6d371d80ddba254ef6f3123128385ff7fd.tar
guix-patches-87257e6d371d80ddba254ef6f3123128385ff7fd.tar.gz
gnu: weechat: Update to 2.9.
* gnu/packages/irc.scm (weechat): Update to 2.9. [arguments]: Remove obsolete test fixes. JavaScript plugins are now disabled by default.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm26
1 files changed, 5 insertions, 21 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index d7f3e6595e..0d9908c771 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -185,14 +185,14 @@ SILC and ICB protocols via plugins.")
(define-public weechat
(package
(name "weechat")
- (version "2.8")
+ (version "2.9")
(source (origin
(method url-fetch)
(uri (string-append "https://weechat.org/files/src/weechat-"
version ".tar.xz"))
(sha256
(base32
- "1301lrb3xnm9dcw3av82rkqjzqxxwwhrq0p6i37h6fxdxnas4gjm"))))
+ "03psmp4hxsb9sz35i4cyz6dcbs3ab73amhyx0w0hv8f3hp1hdd7a"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -215,30 +215,14 @@ SILC and ICB protocols via plugins.")
("tcl" ,tcl)))
(arguments
`(#:configure-flags
- (list "-DENABLE_JAVASCRIPT=OFF"
- "-DENABLE_PHP=OFF"
+ (list "-DENABLE_PHP=OFF"
"-DENABLE_RUBY=OFF"
"-DENABLE_TESTS=ON") ; ‘make test’ fails otherwise
- ;; Tests hang indefinately on non-Intel platforms.
+ ;; Tests hang indefinitely on non-Intel platforms.
#:tests? ,(if (any (cute string-prefix? <> (or (%current-target-system)
(%current-system)))
'("i686" "x86_64"))
- '#t '#f)
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- ;; For reasons best left to the imagination, CppUTest cannot skip
- ;; more than one single test... Resort to manual patching instead.
- ;; See <https://cpputest.github.io/manual.html#command_line>.
- (λ _
- ;; Don't test plugin support for languages we don't enable.
- (substitute* "tests/unit/test-plugins.cpp"
- ((".*\\$\\{plugin.name\\} == (javascript|php|ruby)" all)
- (string-append "// SKIP" all)))
- (substitute* "tests/scripts/test-scripts.cpp"
- ((".*\\{ \"(javascript|php|ruby)\", " all)
- (string-append "// SKIP" all)))
- #t)))))
+ '#t '#f)))
(synopsis "Extensible chat client")
(description "WeeChat (Wee Enhanced Environment for Chat) is an
@dfn{Internet Relay Chat} (IRC) client, which is designed to be light and fast.