summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-24 22:26:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 02:17:03 +0200
commit5a13cf3d1dc635707b82a4412aa116ca49463191 (patch)
treecd8e26bb72e08c7b78b2dd40653f67d3de507df7 /gnu/packages/irc.scm
parent19621509dc6137144f813da6765d168b393ef1e0 (diff)
downloadguix-patches-5a13cf3d1dc635707b82a4412aa116ca49463191.tar
guix-patches-5a13cf3d1dc635707b82a4412aa116ca49463191.tar.gz
gnu: epic5: Return #t from all phases.
* gnu/packages/irc.scm (epic5)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 84a6a60ca4..5a1df6d600 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -404,21 +404,20 @@ other enhancements and bug fixes.")
'())
(setenv "CONFIG_SHELL" (which "bash"))
(setenv "SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- "--with-ipv6" "--with-libarchive"
- ;; We use libressl because openssl does not come
- ;; with the lib/libssl.a which is needed for epic5.
- ;; XXX: No matter which implementation is chosen,
- ;; epic5 fails to connect to tls ports of roundrobin
- ;; irc networks. This however is believed to be an
- ;; protocol issue at epic5 related to ircd.
- (string-append "--with-ssl="
- (assoc-ref %build-inputs "libressl"))
- (string-append "--with-tcl="
- (assoc-ref %build-inputs "tcl")
- "/lib/tclConfig.sh")))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ "--with-ipv6" "--with-libarchive"
+ ;; We use libressl because openssl does not come
+ ;; with the lib/libssl.a which is needed for epic5.
+ ;; XXX: No matter which implementation is chosen,
+ ;; epic5 fails to connect to tls ports of roundrobin
+ ;; irc networks. This however is believed to be an
+ ;; protocol issue at epic5 related to ircd.
+ (string-append "--with-ssl="
+ (assoc-ref %build-inputs "libressl"))
+ (string-append "--with-tcl="
+ (assoc-ref %build-inputs "tcl")
+ "/lib/tclConfig.sh"))))))))
(inputs
`(("libressl" ,libressl)
("ncurses" ,ncurses)