summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-12-17 08:04:57 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-12-17 08:08:00 -0500
commit50489e39417eae6487083bb1912b814f0467ee8d (patch)
tree416ae65145933e1b1e872092e1e6897762a5c5c2 /gnu/packages/irc.scm
parent4fc9698defc4eb49ade04548ca808c7b9ccee234 (diff)
downloadguix-patches-50489e39417eae6487083bb1912b814f0467ee8d.tar
guix-patches-50489e39417eae6487083bb1912b814f0467ee8d.tar.gz
gnu: weechat: Enable documentation and man-pages.
* gnu/packages/irc.scm (weechat)[outputs](doc): New output. [configure-flags](ENABLE_MAN,ENABLE_DOC): New flags. [phases](move-doc): New phase. [native-inputs]: Add ruby-asciidoctor.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index dee9577b4e..278b1bc8fe 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -195,9 +195,11 @@ SILC and ICB protocols via plugins.")
(base32
"1pyb1yaw61cbdg1g4cc22px1wsh8wm0gsx1yzp684idyz25apzna"))))
(build-system cmake-build-system)
+ (outputs '("out" "doc"))
(native-inputs
`(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)
+ ("ruby-asciidoctor" ,ruby-asciidoctor)
;; For tests.
("cpputest" ,cpputest)))
(inputs
@@ -217,7 +219,19 @@ SILC and ICB protocols via plugins.")
(arguments
`(#:configure-flags
(list "-DENABLE_PHP=OFF"
+ "-DENABLE_MAN=ON"
+ "-DENABLE_DOC=ON"
"-DENABLE_TESTS=ON") ; ‘make test’ fails otherwise
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc"))
+ (from (string-append out "/share/doc/weechat"))
+ (to (string-append doc "/share/doc/weechat")))
+ (mkdir-p (string-append doc "/share/doc"))
+ (rename-file from to)))))
;; Tests hang indefinitely on non-Intel platforms.
#:tests? ,(if (any (cute string-prefix? <> (or (%current-target-system)
(%current-system)))