summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-12-10 21:49:25 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-10 21:49:25 +0100
commit32750e8c3ed38df4cafb39cffa878c6851abc899 (patch)
treedcf40b321c3b492bd1d00244c78f72160e66a554 /gnu/packages/irc.scm
parent6104071e483095f9fea9700e0317e84f64102ae2 (diff)
parente1e32303129c5aedc7236d5cc854d6b72ad35daf (diff)
downloadguix-patches-32750e8c3ed38df4cafb39cffa878c6851abc899.tar
guix-patches-32750e8c3ed38df4cafb39cffa878c6851abc899.tar.gz
Merge remote-tracking branch 'signed/master' into core-updates
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 879e698265..5a3aba50b7 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -571,6 +571,39 @@ interface for those who are accustomed to the ircII way of doing things.")
;; distribute binaries.
(license:non-copyleft "http://epicsol.org/copyright")))))
+(define-public litterbox
+ (package
+ (name "litterbox")
+ (version "1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://git.causal.agency/litterbox/snapshot/litterbox-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0ll5d18slngdg2qhaxkvrcq2p1admh0h7sr06wx8347ka0vvrgjl"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:make-flags
+ (list
+ (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("universal-ctags" ,universal-ctags)))
+ (inputs
+ `(("libressl" ,libressl)
+ ("sqlite" ,sqlite)))
+ (home-page "https://code.causal.agency/june/litterbox")
+ (synopsis "TLS-only IRC logger")
+ (description
+"@command{litterbox} is a TLS-only IRC logger. It logs
+events from IRC in a SQLite database, indexing messages for full-text
+search. It is intended for use with the IRC bouncer @command{pounce},
+but can also be used independently as a logging bot.")
+ (license license:gpl3+)))
+
(define-public inspircd
(package
(name "inspircd")