summaryrefslogtreecommitdiff
path: root/gnu/packages/ipfs.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-08-15 17:35:21 -0400
committerLeo Famulari <leo@famulari.name>2019-10-29 11:03:12 -0400
commit35defe61306852ee4ebcd9b42203effd5992bcb2 (patch)
tree687265a28965c55f369dfa5601ef519f62dc39fd /gnu/packages/ipfs.scm
parent561d391ba8711049fea8eca25a1685b2a051b55c (diff)
downloadguix-patches-35defe61306852ee4ebcd9b42203effd5992bcb2.tar
guix-patches-35defe61306852ee4ebcd9b42203effd5992bcb2.tar.gz
gnu: gogoprotobuf: Consolidate packages.
* gnu/packages/golang.scm (go-github-com-gogo-protobuf)[arguments]: Adjust the #:import-path, and skip the tests and build phases. (go-github-com-gogo-protobuf-protoc-gen-gogo, go-github-com-gogo-protobuf-gogoproto, go-github-com-gogo-protobuf-proto): Remove variables. (go-github-com-libp2p-go-libp2p-crypto, go-github-com-libp2p-go-libp2p-peer, go-github-com-libp2p-go-libp2p-metrics): Adjust accordingly. * gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipfs-api, gx, gx-go): Likewise. * gnu/packages/syncthing.scm (syncthing): Likewise.
Diffstat (limited to 'gnu/packages/ipfs.scm')
-rw-r--r--gnu/packages/ipfs.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 79323d8483..39c22262c1 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -86,7 +86,7 @@ that are shared between @command{go-ipfs/commands} and its rewrite
("go-github-com-multiformats-go-multiaddr" ,go-github-com-multiformats-go-multiaddr)
("go-github-com-multiformats-go-multiaddr-net" ,go-github-com-multiformats-go-multiaddr-net)
("go-github-com-btcsuite-btcd-btcec" ,go-github-com-btcsuite-btcd-btcec)
- ("go-github-com-gogo-protobuf-proto" ,go-github-com-gogo-protobuf-proto)
+ ("go-github-com-gogo-protobuf" ,go-github-com-gogo-protobuf)
("go-github-com-minio-blake2b-simd" ,go-github-com-minio-blake2b-simd)
("go-github-com-minio-sha256-simd" ,go-github-com-minio-sha256-simd)
("go-github-com-mr-tron-base58" ,go-github-com-mr-tron-base58)
@@ -138,7 +138,7 @@ that are shared between @command{go-ipfs/commands} and its rewrite
("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
("go-github-com-whyrusleeping-tar-utils" ,go-github-com-whyrusleeping-tar-utils)
("go-github-com-btcsuite-btcd-btcec" ,go-github-com-btcsuite-btcd-btcec)
- ("go-github-com-gogo-protobuf-proto" ,go-github-com-gogo-protobuf-proto)
+ ("go-github-com-gogo-protobuf" ,go-github-com-gogo-protobuf)
("go-github-com-sabhiram-go-gitignore" ,go-github-com-sabhiram-go-gitignore)
("go-github-com-urfave-cli" ,go-github-com-urfave-cli)
("go-github-com-whyrusleeping-json-filter" ,go-github-com-whyrusleeping-json-filter)
@@ -198,7 +198,7 @@ powerful and simple.")
("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
("go-github-com-whyrusleeping-tar-utils" ,go-github-com-whyrusleeping-tar-utils)
("go-github-com-btcsuite-btcd-btcec" ,go-github-com-btcsuite-btcd-btcec)
- ("go-github-com-gogo-protobuf-proto" ,go-github-com-gogo-protobuf-proto)
+ ("go-github-com-gogo-protobuf" ,go-github-com-gogo-protobuf)
("go-github-com-sabhiram-go-gitignore" ,go-github-com-sabhiram-go-gitignore)
("go-github-com-urfave-cli" ,go-github-com-urfave-cli)
("go-github-com-whyrusleeping-progmeter" ,go-github-com-whyrusleeping-progmeter)