summaryrefslogtreecommitdiff
path: root/gnu/packages/inkscape.scm
diff options
context:
space:
mode:
authorBoris A. Dekshteyn <boris.dekshteyn@gmail.com>2021-06-15 01:27:44 +1200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-18 13:12:17 +0200
commit624a6b60b5f4051ec38829e9c9d2adbc54a093f9 (patch)
tree43ea2e21b01f39d9a04665bb732985ce88fc87c3 /gnu/packages/inkscape.scm
parent4985a4272497bf9ba87a2190353d915da9b55906 (diff)
downloadguix-patches-624a6b60b5f4051ec38829e9c9d2adbc54a093f9.tar
guix-patches-624a6b60b5f4051ec38829e9c9d2adbc54a093f9.tar.gz
gnu: inkscape: Update to version 1.1.
* gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/inkscape.scm (inkscape-1.0) Rename to inkscape-1.1. * gnu/packages/inkscape.scm (inkscape-1.1) Update to version 1.1. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/inkscape.scm')
-rw-r--r--gnu/packages/inkscape.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 075f901b2d..46c8c4cc34 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -117,19 +117,20 @@ apart is its use of Scalable Vector Graphics (SVG), an XML-based W3C standard,
as the native format.")
(license license:gpl2+)))
-(define-public inkscape-1.0
+(define-public inkscape-1.1
(package
(name "inkscape")
- (version "1.0.2")
+ (version "1.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://media.inkscape.org/dl/"
"resources/file/"
"inkscape-" version ".tar.xz"))
+ (patches (search-patches "inkscape-1.1-fix-build-witch-gcc7.5.patch"))
(sha256
(base32
- "12krl97a00gdcxxibsb7g2lgx5458mhx2437x0hvz350242j6gns"))
+ "1rlm2wqg8bgdxkdvnadh49wfp0mrbrk7d8n4vdcjyw6z7z7firki"))
(modules '((guix build utils)
(ice-9 format)))
(snippet
@@ -188,7 +189,7 @@ endif()~%~%"
(string-append "#include " quote
(basename source-dir)))
...))))))
- (unbundle ("2geom" "src/2geom" #t)
+ (unbundle ("2geom" "src/3rdparty/2geom" #t)
;; libcroco cannot be unbundled as it is heavily
;; modified (see:
;; https://gitlab.com/inkscape/inkscape/issues/876#note_276114904).