summaryrefslogtreecommitdiff
path: root/gnu/packages/inkscape.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-05 11:58:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:15 -0500
commit50db3459cb20132a811b6b071545e76757ae8fa5 (patch)
treea2073c28b4463d8b1416d0d22ab33008a66b54a9 /gnu/packages/inkscape.scm
parent9b6a23e5249a117357fd6a8958bdbf6d4d23c428 (diff)
downloadguix-patches-50db3459cb20132a811b6b071545e76757ae8fa5.tar
guix-patches-50db3459cb20132a811b6b071545e76757ae8fa5.tar.gz
gnu: inkscape: Remove the legacy 0.92 version.
The older 0.92 Inkscape package was previously kept because of problems building lib2geom on the ARM architectures. As this no longer appears to be a problem (tested on the overdrive1 machine), finally replace the older Inkscape by the newer 1.1 release. * gnu/packages/inkscape.scm (inkscape-1.1): Delete variable, moving the package definition to... (inkscape): ... the now single inkscape variable. Remove trailing #t. [tests?]: Remove. [phases]{generate-gdk-pixbuf-loaders-cache-file}: Add phase.
Diffstat (limited to 'gnu/packages/inkscape.scm')
-rw-r--r--gnu/packages/inkscape.scm79
1 files changed, 8 insertions, 71 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index ded2b01ec7..2328410760 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Boris A. Dekshteyn <boris.dekshteyn@gmail.com>
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
@@ -55,71 +55,6 @@
(define-public inkscape
(package
(name "inkscape")
- (version "0.92.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://media.inkscape.org/dl/"
- "resources/file/"
- "inkscape-" version ".tar.bz2"))
- (patches (search-patches "inkscape-poppler-0.76.patch"))
- (sha256
- (base32
- "0pjinhjibfsz1aywdpgpj3k23xrsszpj4a1ya5562dkv2yl2vv2p"))))
- (build-system cmake-build-system)
- (inputs
- `(("aspell" ,aspell)
- ("gtkmm" ,gtkmm-2)
- ("gtk" ,gtk+-2)
- ("gsl" ,gsl)
- ("poppler" ,poppler)
- ("libpng" ,libpng)
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)
- ("libgc" ,libgc)
- ("freetype" ,freetype)
- ("popt" ,popt)
- ("potrace" ,potrace)
- ("python" ,python-wrapper)
- ("lcms" ,lcms)
- ("boost" ,boost)))
- (native-inputs
- `(("intltool" ,intltool)
- ("glib" ,glib "bin")
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)))
- ;; FIXME: tests require gmock
- (arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-icon-cache-generator
- (lambda _
- (substitute* "share/icons/application/CMakeLists.txt"
- (("gtk-update-icon-cache") "true"))
- #t))
- (add-after 'unpack 'adjust-for-new-poppler
- (lambda _
- (substitute* (find-files "src/extension/internal/pdfinput")
- ;; Needed for Poppler 0.82.
- (("Unicode \\*u") "Unicode const *u")
- ;; Needed for Poppler 0.83.
- (("\\(GfxPath") "(const GfxPath")
- (("GfxSubpath") "const GfxSubpath")
- (("new GlobalParams\\(\\)")
- "std::unique_ptr<GlobalParams>(new GlobalParams())")
- (("new GlobalParams\\(poppler_datadir\\)")
- "std::unique_ptr<GlobalParams>(new GlobalParams(poppler_datadir))"))
- #t)))))
- (home-page "https://inkscape.org/")
- (synopsis "Vector graphics editor")
- (description "Inkscape is a vector graphics editor. What sets Inkscape
-apart is its use of Scalable Vector Graphics (SVG), an XML-based W3C standard,
-as the native format.")
- (license license:gpl2+)))
-
-(define-public inkscape-1.1
- (package
- (name "inkscape")
(version "1.1.1")
(source
(origin
@@ -212,8 +147,7 @@ endif()~%~%"
((".*find_package\\(DoubleConversion.*") ""))))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #t
- #:test-target "check" ;otherwise some test binaries are missing
+ `(#:test-target "check" ;otherwise some test binaries are missing
#:imported-modules (,@%cmake-build-system-modules
(guix build glib-or-gtk-build-system))
#:modules ((guix build cmake-build-system)
@@ -221,6 +155,9 @@ endif()~%~%"
(guix build utils))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'generate-gdk-pixbuf-loaders-cache-file))
(add-after 'unpack 'patch-icon-cache-generator
(lambda _
(substitute* "share/icons/application/CMakeLists.txt"
@@ -236,8 +173,7 @@ endif()~%~%"
(add-after 'unpack 'set-home
;; Mute Inkscape warnings during tests.
(lambda _
- (setenv "HOME" (getcwd))
- (format #t "ARGS is set to: ~a" (getenv "ARGS"))))
+ (setenv "HOME" (getcwd))))
;; Move the check phase after the install phase, as when run in the
;; tests, Inkscape relies on files that are not yet installed, such
;; as the "share/inkscape/ui/units.xml" file.
@@ -253,7 +189,8 @@ endif()~%~%"
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(wrap-program (string-append out "/bin/inkscape")
- `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH"))))))))))
+ `("GUIX_PYTHONPATH" ":" prefix
+ (,(getenv "GUIX_PYTHONPATH"))))))))))
(inputs
`(("aspell" ,aspell)
("autotrace" ,autotrace)