summaryrefslogtreecommitdiff
path: root/gnu/packages/inkscape.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-14 23:16:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-14 23:16:33 -0400
commit1afa2c5ca0c5904bd9de70a48dd7d0a6275d5d3f (patch)
tree96adc762c4e7d909fa717e5abe171517e7c9980d /gnu/packages/inkscape.scm
parent3d7726b7f2fc14aa5fc125b3705329efb86f81fd (diff)
downloadguix-patches-1afa2c5ca0c5904bd9de70a48dd7d0a6275d5d3f.tar
guix-patches-1afa2c5ca0c5904bd9de70a48dd7d0a6275d5d3f.tar.gz
gnu: inkscape: Add the glib-or-gtk-build-system phases.
This fixes an issue where an improperly set XDG_DATA_DIRS environment variable would cause a segfault when opening the 'Save As' menu of Inkscape. See: <https://lists.gnu.org/archive/html/help-guix/2020-06/msg00093.html>. * gnu/packages/inkscape.scm (inkscape-1.0)[arguments]: Import the (guix build glib-or-gtk-build-system) module. [phases]: Add the glib-or-gtk-compile-schemas and glib-or-gtk-wrap phases. Reported-by: Thorsten Wilms <t_w_@freenet.de>
Diffstat (limited to 'gnu/packages/inkscape.scm')
-rw-r--r--gnu/packages/inkscape.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index b0707d6eff..85b0ba9fcf 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -213,6 +213,11 @@ endif()~%~%"
(arguments
`(#:tests? #t
#:test-target "check" ;otherwise some test binaries are missing
+ #:imported-modules (,@%cmake-build-system-modules
+ (guix build glib-or-gtk-build-system))
+ #:modules ((guix build cmake-build-system)
+ ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ (guix build utils))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-icon-cache-generator
@@ -240,7 +245,11 @@ endif()~%~%"
;; as the "share/inkscape/ui/units.xml" file.
(delete 'check)
(add-after 'install 'check
- (assoc-ref %standard-phases 'check)))))
+ (assoc-ref %standard-phases 'check))
+ (add-after 'install 'glib-or-gtk-compile-schemas
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+ (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(inputs
`(("aspell" ,aspell)
("autotrace" ,autotrace)