summaryrefslogtreecommitdiff
path: root/gnu/packages/inkscape.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 14:25:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-03 14:27:51 +0200
commit075df3d3e2f86ad2548075969b34402a3c40ec42 (patch)
tree303b422a84ce5ee1fccff610eaf83b20919e8b87 /gnu/packages/inkscape.scm
parentaba40a6b7fdce56fe439668b3152ae4d4ddd1551 (diff)
parentb2721c3656e0ddf76dcccccfbacaaa309d2f47fe (diff)
downloadguix-patches-075df3d3e2f86ad2548075969b34402a3c40ec42.tar
guix-patches-075df3d3e2f86ad2548075969b34402a3c40ec42.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/inkscape.scm')
-rw-r--r--gnu/packages/inkscape.scm21
1 files changed, 7 insertions, 14 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 1fd328eb1c..ded2b01ec7 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -120,17 +120,15 @@ as the native format.")
(define-public inkscape-1.1
(package
(name "inkscape")
- (version "1.1")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://media.inkscape.org/dl/"
"resources/file/"
"inkscape-" version ".tar.xz"))
- (patches (search-patches "inkscape-1.1-fix-build-witch-gcc7.5.patch"))
(sha256
- (base32
- "1rlm2wqg8bgdxkdvnadh49wfp0mrbrk7d8n4vdcjyw6z7z7firki"))
+ (base32 "1bvqg5xfs3m6r7qfdhmgzwhd1hx8wvg3nhvhmalwzcdm6ffhpjmf"))
(modules '((guix build utils)
(ice-9 format)))
(snippet
@@ -211,8 +209,7 @@ endif()~%~%"
;; Lift the requirement on the double-conversion library, as
;; it is only needed by lib2geom, which is now unbundled.
(substitute* "CMakeScripts/DefineDependsandFlags.cmake"
- ((".*find_package\\(DoubleConversion.*") ""))
- #t))))
+ ((".*find_package\\(DoubleConversion.*") ""))))))
(build-system cmake-build-system)
(arguments
`(#:tests? #t
@@ -227,8 +224,7 @@ endif()~%~%"
(add-after 'unpack 'patch-icon-cache-generator
(lambda _
(substitute* "share/icons/application/CMakeLists.txt"
- (("gtk-update-icon-cache") "true"))
- #t))
+ (("gtk-update-icon-cache") "true"))))
(add-after 'unpack 'disable-latex-export-tests
;; FIXME: For some reason the test.pdf_tex file generated by the
;; "--export-latex" lacks "some text" in its content when run in
@@ -236,14 +232,12 @@ endif()~%~%"
(lambda _
(substitute* "testfiles/cli_tests/CMakeLists.txt"
(("add_cli_test\\(export-latex")
- "message(TEST_DISABLED: export-latex"))
- #t))
+ "message(TEST_DISABLED: export-latex"))))
(add-after 'unpack 'set-home
;; Mute Inkscape warnings during tests.
(lambda _
(setenv "HOME" (getcwd))
- (format #t "ARGS is set to: ~a" (getenv "ARGS"))
- #t))
+ (format #t "ARGS is set to: ~a" (getenv "ARGS"))))
;; Move the check phase after the install phase, as when run in the
;; tests, Inkscape relies on files that are not yet installed, such
;; as the "share/inkscape/ui/units.xml" file.
@@ -259,8 +253,7 @@ endif()~%~%"
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(wrap-program (string-append out "/bin/inkscape")
- `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))))
- #t)))))
+ `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH"))))))))))
(inputs
`(("aspell" ,aspell)
("autotrace" ,autotrace)