summaryrefslogtreecommitdiff
path: root/gnu/packages/imagemagick.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2021-03-27 07:16:50 -0400
committerMark H Weaver <mhw@netris.org>2021-03-27 19:48:39 -0400
commitbe3aef49ed1d8a0f13d64cd5cf6f280500876efd (patch)
tree0302a83e3221baa2f06043ce75809c91ba0c1e58 /gnu/packages/imagemagick.scm
parent7c2b840d6c586f80fe22a862ce4e362c997559a5 (diff)
downloadguix-patches-be3aef49ed1d8a0f13d64cd5cf6f280500876efd.tar
guix-patches-be3aef49ed1d8a0f13d64cd5cf6f280500876efd.tar.gz
gnu: imagemagick: Add 'imagemagick/stable' variant.
* gnu/packages/imagemagick.scm (imagemagick/stable): New variable. (imagemagick): This is now an alias to 'imagemagick/stable'.
Diffstat (limited to 'gnu/packages/imagemagick.scm')
-rw-r--r--gnu/packages/imagemagick.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index cc5f1de4bf..528fb9eb25 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -44,7 +44,19 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
-(define-public imagemagick
+;; This is a variant of the 'imagemagick' package that is not updated often.
+;; It is intended to be used as a native-input at build-time only, e.g. by
+;; 'gtk-doc' (via 'dblatex') for generating package documentation. This
+;; allows the main 'imagemagick' package to be freely updated on the 'master'
+;; branch without triggering an excessive number of rebuilds.
+;;
+;; Normally the grafts mechanism would be used, but there are often
+;; difficulties grafting imagemagick, e.g. because upstream changes the ABI
+;; between micro version updates. Also, the overwhelming majority of
+;; dependencies on imagemagick are via 'gtk-doc' in 'native-inputs', where
+;; grafting is ineffective. See:
+;; <https://lists.gnu.org/archive/html/guix-devel/2021-03/msg00381.html>.
+(define-public imagemagick/stable
(package
(name "imagemagick")
;; The 7 release series has an incompatible API, while the 6 series is still
@@ -127,6 +139,9 @@ transform images, adjust image colors, apply various special effects, or draw
text, lines, polygons, ellipses and Bézier curves.")
(license (license:fsf-free "http://www.imagemagick.org/script/license.php"))))
+(define-public imagemagick
+ imagemagick/stable)
+
(define-public perl-image-magick
(package
(name "perl-image-magick")