summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-08-08 15:53:12 -0400
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:57 -0400
commitf4f4037fcd237594f5c8211a0fd74a9af3bcd612 (patch)
tree054a4c2ecb7074286a12881cfa6aeb497982cd94 /gnu/packages/image.scm
parente012c294634dae6b1fd7f8537dd2f57520c8c524 (diff)
downloadguix-patches-f4f4037fcd237594f5c8211a0fd74a9af3bcd612.tar
guix-patches-f4f4037fcd237594f5c8211a0fd74a9af3bcd612.tar.gz
gnu: vigra: Update to 1.11.1-0.9b514fa.
* gnu/packages/image.scm (vigra): Update to 1.11.1-0.9b514fa. [source]: Use git-fetch. Remove obsolete patch. * gnu/packages/patches/vigra-python-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm152
1 files changed, 79 insertions, 73 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 19bbb2d63d..72fda9eb8c 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1175,79 +1175,85 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
(home-page "http://freeimage.sourceforge.net")))
(define-public vigra
- (package
- (name "vigra")
- (version "1.11.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ukoethe/vigra/releases/download/"
- "Version-" (string-join (string-split version #\.) "-")
- "/vigra-" version "-src.tar.gz"))
- (patches (search-patches "vigra-python-compat.patch"))
- (sha256 (base32
- "1bqs8vx5i1bzamvv563i24gx2xxdidqyxh9iaj46mbznhc84wmm5"))))
- (build-system cmake-build-system)
- (inputs
- `(("boost" ,boost)
- ("fftw" ,fftw)
- ("fftwf" ,fftwf)
- ("hdf5" ,hdf5)
- ("ilmbase" ,ilmbase) ; propagated by openexr, but needed explicitly
- ; to create a configure-flag
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("openexr" ,openexr)
- ("python" ,python-wrapper)
- ("python-numpy" ,python-numpy)
- ("zlib" ,zlib)))
- (native-inputs
- `(("doxygen" ,doxygen)
- ("python-nose" ,python-nose)
- ("sphinx" ,python-sphinx)))
- (arguments
- `(#:test-target "check"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-broken-tests
- (lambda _
- ;; See https://github.com/ukoethe/vigra/issues/432
- (substitute* "test/fourier/CMakeLists.txt"
- (("VIGRA_ADD_TEST.*") ""))
- ;; This test fails with Numpy 1.15:
- ;; <https://github.com/ukoethe/vigra/issues/436>.
- (substitute* "vigranumpy/test/CMakeLists.txt"
- (("test1\\.py") ""))
- #t)))
- #:configure-flags
- (list "-Wno-dev" ; suppress developer mode with lots of warnings
- (string-append "-DVIGRANUMPY_INSTALL_DIR="
- (assoc-ref %outputs "out")
- "/lib/python"
- ,(version-major+minor (package-version python))
- "/site-packages")
- ;; OpenEXR is not enabled by default.
- "-DWITH_OPENEXR=1"
- ;; Fix rounding error on 32-bit machines
- "-DCMAKE_C_FLAGS=-ffloat-store"
- ;; The header files of ilmbase are not found when included
- ;; by the header files of openexr, and an explicit flag
- ;; needs to be set.
- (string-append "-DCMAKE_CXX_FLAGS=-I"
- (assoc-ref %build-inputs "ilmbase")
- "/include/OpenEXR"
- " -ffloat-store"))))
- (synopsis "Computer vision library")
- (description
- "VIGRA stands for Vision with Generic Algorithms. It is an image
-processing and analysis library that puts its main emphasis on customizable
-algorithms and data structures. It is particularly strong for
-multi-dimensional image processing.")
- (license license:expat)
- (home-page "https://ukoethe.github.io/vigra/")
- (properties '((max-silent-time . 7200))))) ;2 hours, to avoid timing out
-
+ (let ((commit "9b514fa00a136f5fd81bb57ee9f6293c333ffc1f")
+ (revision "0"))
+ (package
+ (name "vigra")
+ (version (git-version "1.11.1" revision commit))
+ (source
+ (origin
+ ;; The last release is 1.11.1, from 2017. It's becoming more and more
+ ;; difficult to build this old release, and the upstream developers
+ ;; suggest on their home page to build from the Git repo, saying "It is
+ ;; generally safe to use the 'master' branch of the development snapshot,
+ ;; as we avoid uploading untested or incompatible changes to this branch."
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ukoethe/vigra")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256 (base32
+ "1vzlypviala109imwxkp46lqhhxszf79ypfb8wxg6z7g02j7mm73"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("boost" ,boost)
+ ("fftw" ,fftw)
+ ("fftwf" ,fftwf)
+ ("hdf5" ,hdf5)
+ ("ilmbase" ,ilmbase) ; propagated by openexr, but needed explicitly
+ ; to create a configure-flag
+ ("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("openexr" ,openexr)
+ ("python" ,python-wrapper)
+ ("python-numpy" ,python-numpy)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("python-nose" ,python-nose)
+ ("sphinx" ,python-sphinx)))
+ (arguments
+ `(#:test-target "check"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-broken-tests
+ (lambda _
+ ;; See https://github.com/ukoethe/vigra/issues/432
+ (substitute* "test/fourier/CMakeLists.txt"
+ (("VIGRA_ADD_TEST.*") ""))
+ ;; This test fails with Numpy 1.15:
+ ;; <https://github.com/ukoethe/vigra/issues/436>.
+ (substitute* "vigranumpy/test/CMakeLists.txt"
+ (("test1\\.py") ""))
+ #t)))
+ #:configure-flags
+ (list "-Wno-dev" ; suppress developer mode with lots of warnings
+ (string-append "-DVIGRANUMPY_INSTALL_DIR="
+ (assoc-ref %outputs "out")
+ "/lib/python"
+ ,(version-major+minor (package-version python))
+ "/site-packages")
+ ;; OpenEXR is not enabled by default.
+ "-DWITH_OPENEXR=1"
+ ;; Fix rounding error on 32-bit machines
+ "-DCMAKE_C_FLAGS=-ffloat-store"
+ ;; The header files of ilmbase are not found when included
+ ;; by the header files of openexr, and an explicit flag
+ ;; needs to be set.
+ (string-append "-DCMAKE_CXX_FLAGS=-I"
+ (assoc-ref %build-inputs "ilmbase")
+ "/include/OpenEXR"
+ " -ffloat-store"))))
+ (synopsis "Computer vision library")
+ (description
+ "VIGRA stands for Vision with Generic Algorithms. It is an image
+ processing and analysis library that puts its main emphasis on customizable
+ algorithms and data structures. It is particularly strong for
+ multi-dimensional image processing.")
+ (license license:expat)
+ (home-page "https://ukoethe.github.io/vigra/")
+ (properties '((max-silent-time . 7200)))))) ;2 hours, to avoid timing out
(define-public vigra-c
(let* ((commit "66ff4fa5a7d4a77415caa676a45c2c6ea16562e7")