summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-07-05 14:26:03 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-05 18:10:29 +0200
commiteafd039005815fee5f7ddcbb527c6a95cf2afe5a (patch)
treec704b447209cf1173775d70d2b56248fed777eb0 /gnu/packages/image.scm
parentb35af249388edd3c089090ce58e74fd04dbb6919 (diff)
downloadguix-patches-eafd039005815fee5f7ddcbb527c6a95cf2afe5a.tar
guix-patches-eafd039005815fee5f7ddcbb527c6a95cf2afe5a.tar.gz
gnu: hugin: Build against Exiv2 0.26.
* gnu/packages/image.scm (exiv2-0.26): New variable. * gnu/packages/photo.scm (hugin)[inputs]: Use it instead of EXIV2.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index ef477fa6f1..fabc2fb2d1 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Alex Kost <alezost@gmail.com>
@@ -1066,6 +1066,34 @@ and XMP metadata of images in various formats.")
;; <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
(license license:gpl2+)))
+(define-public exiv2-0.26
+ (package
+ (inherit exiv2)
+ (version "0.26")
+ (source (origin
+ (method url-fetch)
+ (uri (list (string-append "https://www.exiv2.org/builds/exiv2-"
+ version "-trunk.tar.gz")
+ (string-append "https://www.exiv2.org/exiv2-"
+ version ".tar.gz")
+ (string-append "https://fossies.org/linux/misc/exiv2-"
+ version ".tar.gz")))
+ (patches (search-patches "exiv2-CVE-2017-14860.patch"
+ "exiv2-CVE-2017-14859-14862-14864.patch"))
+ (sha256
+ (base32
+ "1yza317qxd8yshvqnay164imm0ks7cvij8y8j86p1gqi1153qpn7"))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f)) ; no `check' target
+ (propagated-inputs
+ `(("expat" ,expat)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("intltool" ,intltool)))
+
+ ;; People should rely on the newer version, so don't expose it.
+ (properties `((hidden? . #t)))))
+
(define-public devil
(package
(name "devil")