summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-18 17:32:24 +0200
committerMarius Bakke <marius@gnu.org>2020-10-19 00:12:31 +0200
commitdcafa89cf0b9124d0567264eb2ef4d730b1e75bb (patch)
treee0136b14f7390f81a6be1592f97d6e67df3b6a10 /gnu/packages/image.scm
parentd76b668cd6595d08761fa75d749ec943e792ea6f (diff)
downloadguix-patches-dcafa89cf0b9124d0567264eb2ef4d730b1e75bb.tar
guix-patches-dcafa89cf0b9124d0567264eb2ef4d730b1e75bb.tar.gz
gnu: extempore: Inline custom package variants.
Except novel ones without suitable replacements in Guix. * gnu/packages/music.scm (portmidi-for-extempore): Remove variable, and move to ... (extempore)[inputs]: ... here. * gnu/packages/llvm.scm (llvm-for-extempore): Likewise. * gnu/packages/image.scm (stb-image-for-extempore): Likewise.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 5f8711c869..36d7dd606f 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1530,33 +1530,6 @@ files (known as @dfn{steganography}). Neither color nor sample frequencies are
changed, making the embedding resistant against first-order statistical tests.")
(license license:gpl2+)))
-(define-public stb-image-for-extempore
- (let ((revision "1")
- (commit "152a250a702bf28951bb0220d63bc0c99830c498"))
- (package
- (name "stb-image-for-extempore")
- (version (string-append "0-" revision "." (string-take commit 9)))
- (source
- (origin (method git-fetch)
- (uri (git-reference
- (url "https://github.com/extemporelang/stb")
- (commit commit)))
- (sha256
- (base32
- "0y0aa20pj9311x2ii06zg8xs34idg14hfgldqc5ymizc6cf1qiqv"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; no tests included
- ;; Extempore refuses to build on architectures other than x86_64
- (supported-systems '("x86_64-linux"))
- (home-page "https://github.com/extemporelang/stb")
- (synopsis "Image library for Extempore")
- (description
- "This package is a collection of assorted single-file libraries. Of
-all included libraries only the image loading and decoding library is
-installed as @code{stb_image}.")
- (license license:public-domain))))
-
(define-public optipng
(package
(name "optipng")