summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-03 12:08:33 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:41 +0200
commitc42526e9473d6f78e029b6e3061938fb9d40f7e5 (patch)
treefff66ccce03a88eeb047fa8d3216e349109fff51 /gnu/packages/image.scm
parent9068eb166d298ed23488be1b97001dd18fd0f3bb (diff)
downloadguix-patches-c42526e9473d6f78e029b6e3061938fb9d40f7e5.tar
guix-patches-c42526e9473d6f78e029b6e3061938fb9d40f7e5.tar.gz
gnu: Add iqa.
* gnu/packages/image.scm (iqa): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 3061d19797..2f354974d2 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -94,6 +94,38 @@
#:use-module (guix deprecation)
#:use-module (srfi srfi-1))
+(define-public iqa
+ (package
+ (name "iqa")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://sourceforge.net/projects/iqa/files/"
+ "1.1.2%20Release/iqa_1.1.2_src.tar.gz/download"))
+ (sha256
+ (base32 "00mgwy031ammab6bwmd1whhvqv3fxy1cs1igabq0n3ag12zhjs77"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib")))
+ (install-file "build/debug/libiqa.a" lib)
+ #t))))))
+ (synopsis "Image Quality Assessment")
+ (description "IQA is a C library for objectively measuring image/video
+quality. It implements many popular algorithms, such as MS-SSIM, MS-SSIM*,
+SIMM, MSE, and PSNR. It is designed to be fast, accurate, and reliable. All
+code is Valgrind-clean and unit tested.")
+ (home-page "https://sourceforge.net/projects/iqa/")
+ (license license:bsd-4)))
+
(define-public libpng
(package
(name "libpng")