summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-17 16:17:20 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-17 16:27:15 +0200
commit9ff87bb99614923fa3336ab4bbf22e3444709b48 (patch)
treefa169a6cc0fdc8d92bb4c4a4f265afc2ba29a890 /gnu/packages/image.scm
parentae71bef532d6b1c9d1481a3ac65827f148b1e45b (diff)
parent9e8e252026f558933bdd9cfc26a75d13954b3e8e (diff)
downloadguix-patches-9ff87bb99614923fa3336ab4bbf22e3444709b48.tar
guix-patches-9ff87bb99614923fa3336ab4bbf22e3444709b48.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm73
1 files changed, 73 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 4463007c74..7b6c8b3e0b 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1428,6 +1428,40 @@ PNG, and performs PNG integrity checks and corrections.")
(home-page "http://optipng.sourceforge.net/")
(license license:zlib)))
+(define-public pngsuite
+ (package
+ (name "pngsuite")
+ (version "2017jul19")
+ (source
+ (origin
+ (method url-fetch/tarbomb)
+ (uri (string-append "http://www.schaik.com/pngsuite2011/PngSuite-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "1j7xgd9iffcnpphhzz9ld9ybrjmx9brhq0803g0450ssr52b5502"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; there is no test target
+ #:license-file-regexp "PngSuite.LICENSE"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (copy-recursively "." (string-append out "/"))
+ #t)))
+ (delete 'build)
+ (delete 'configure))))
+ (home-page "http://www.schaik.com/pngsuite2011/pngsuite.html")
+ (synopsis "Example PNGs for use in test suites")
+ (description "Collection of graphics images created to test PNG
+applications like viewers, converters and editors. As far as that is
+possible, all formats supported by the PNG standard are represented.")
+ (license (license:fsdg-compatible "file://PngSuite.LICENSE" "Permission to
+use, copy, modify and distribute these images for any purpose and without fee
+is hereby granted."))))
+
(define-public libjpeg-turbo
(package
(name "libjpeg-turbo")
@@ -1755,3 +1789,42 @@ identical visual appearance.")
to the standard output. It works well together with grim.")
;; MIT license.
(license license:expat)))
+
+(define-public sng
+ (package
+ (name "sng")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/sng/sng-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "06a6ydvx9xb3vxvrzdrg3hq0rjwwj9ibr7fyyxjxq6qx1j3mb70i"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'link-pngsuite
+ ;; tests expect pngsuite in source dir
+ (lambda* (#:key inputs #:allow-other-keys)
+ (symlink (assoc-ref inputs "pngsuite") "pngsuite")
+ #t)))
+ #:configure-flags
+ (list (string-append "--with-rgbtxt="
+ (assoc-ref %build-inputs "xorg-rgb")
+ "/share/X11/rgb.txt"))))
+ (inputs `(("xorg-rgb" ,xorg-rgb)
+ ("libpng" ,libpng)))
+ (native-inputs `(("pngsuite" ,pngsuite)))
+ (home-page "http://sng.sourceforge.net")
+ (synopsis "Markup language for representing PNG contents")
+ (description "SNG (Scriptable Network Graphics) is a minilanguage designed
+specifically to represent the entire contents of a PNG (Portable Network
+Graphics) file in an editable form. Thus, SNGs representing elaborate
+graphics images and ancillary chunk data can be readily generated or modified
+using only text tools.
+
+SNG is implemented by a compiler/decompiler called sng that
+losslessly translates between SNG and PNG.")
+ (license license:zlib)))