summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-01 22:39:23 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-02 00:38:52 +0200
commit8b5b3acab3c98bf58e14fc55399a8b3a098094ef (patch)
tree0141de11ed464e69942130ad36758e1f7757bfc3 /gnu/packages/image.scm
parent8de1979d7c2ad52100bd37ae0180e598e68d1c7c (diff)
downloadguix-patches-8b5b3acab3c98bf58e14fc55399a8b3a098094ef.tar
guix-patches-8b5b3acab3c98bf58e14fc55399a8b3a098094ef.tar.gz
gnu: libpng: Remove graft for 1.6.37.
* gnu/packages/image.scm (libpng): Update to 1.6.37. [replacement]: Remove field. (libpng-1.6.37): Remove variable.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm24
1 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 9adbf78390..10c2f82153 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -86,8 +86,7 @@
(define-public libpng
(package
(name "libpng")
- (version "1.6.36")
- (replacement libpng-1.6.37)
+ (version "1.6.37")
(source (origin
(method url-fetch)
(uri (list (string-append "mirror://sourceforge/libpng/libpng16/"
@@ -100,7 +99,7 @@
"/libpng16/libpng-" version ".tar.xz")))
(sha256
(base32
- "06d35a3xz2a0kph82r56hqm1fn8fbwrqs07xzmr93dx63x695szc"))))
+ "1jl8in381z0128vgxnvn33nln6hzckl7l7j9nqvkaf1m9n1p0pjh"))))
(build-system gnu-build-system)
;; libpng.la says "-lz", so propagate it.
@@ -113,25 +112,6 @@ library. It supports almost all PNG features and is extensible.")
(license license:zlib)
(home-page "http://www.libpng.org/pub/png/libpng.html")))
-;; This graft exists to fix CVE-2018-14048, CVE-2018-14550, and CVE-2019-7317.
-(define-public libpng-1.6.37
- (package
- (inherit libpng)
- (version "1.6.37")
- (source (origin
- (method url-fetch)
- (uri (list (string-append "mirror://sourceforge/libpng/libpng16/"
- version "/libpng-" version ".tar.xz")
- (string-append
- "ftp://ftp.simplesystems.org/pub/libpng/png/src"
- "/libpng16/libpng-" version ".tar.xz")
- (string-append
- "ftp://ftp.simplesystems.org/pub/libpng/png/src/history"
- "/libpng16/libpng-" version ".tar.xz")))
- (sha256
- (base32
- "1jl8in381z0128vgxnvn33nln6hzckl7l7j9nqvkaf1m9n1p0pjh"))))))
-
;; libpng-apng should be updated when the APNG patch is released:
;; <https://bugs.gnu.org/27556>
(define-public libpng-apng