summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorAlexandr Vityazev <avityazev@posteo.org>2021-09-25 13:04:50 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-13 11:48:03 +0200
commit859d5a1f1d8486b509a80769a33dd546a6d4c1b2 (patch)
tree32a19fae6fd32183bd38644bbcea19039a38fa32 /gnu/packages/image.scm
parent4779c90184b21b779a3d09c7a3cac92ce6f8f7dc (diff)
downloadguix-patches-859d5a1f1d8486b509a80769a33dd546a6d4c1b2.tar
guix-patches-859d5a1f1d8486b509a80769a33dd546a6d4c1b2.tar.gz
gnu: swappy: Add propagated-inputs.
Add font-awesome to propagated-inputs to properly render the icons. * gnu/packages/image.scm (swappy)[propagated-inputs]: Add font-awesome; [use-modules]: Add (gnu packages fonts). Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index bdcf43c03f..5bce96a81e 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -91,6 +91,7 @@
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages fonts)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -1871,6 +1872,9 @@ Features:
(inputs
`(("gtk+" ,gtk+)
("libnotify" ,libnotify)))
+ (propagated-inputs
+ ;; Needed to properly render the icons.
+ `(("font-awesome" ,font-awesome)))
(home-page "https://github.com/jtheoof/swappy")
(synopsis "Grab and edit on the fly snapshots of a Wayland compositor")
(description