summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-27 23:33:48 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-27 23:33:48 +0200
commit5cc1075a76392666d3d733837f5c6252b1e48002 (patch)
treeaff2a303881a6fe53021a6e78a767958e608719b /gnu/packages/image.scm
parent9c2563a80b6f1d8fb8677f5314e6180ea9916aa5 (diff)
parentc30d117822a8ca26cd8c06c0a3974955bef68eac (diff)
downloadguix-patches-5cc1075a76392666d3d733837f5c6252b1e48002.tar
guix-patches-5cc1075a76392666d3d733837f5c6252b1e48002.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm28
1 files changed, 10 insertions, 18 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 390b74c333..0e5631bbe3 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1006,27 +1006,19 @@ channels.")
(define-public exiv2
(package
(name "exiv2")
- (version "0.26")
- (source (origin
- (method url-fetch)
- (uri (list (string-append "https://www.exiv2.org/builds/exiv2-"
- version "-trunk.tar.gz")
- (string-append "https://www.exiv2.org/exiv2-"
- version ".tar.gz")
- (string-append "https://fossies.org/linux/misc/exiv2-"
- version ".tar.gz")))
- (patches (search-patches "exiv2-CVE-2017-14860.patch"
- "exiv2-CVE-2017-14859-14862-14864.patch"))
- (sha256
- (base32
- "1yza317qxd8yshvqnay164imm0ks7cvij8y8j86p1gqi1153qpn7"))))
- (build-system gnu-build-system)
- (arguments '(#:tests? #f)) ; no `check' target
+ (version "0.27.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.exiv2.org/builds/exiv2-" version
+ "-Source.tar.gz"))
+ (sha256
+ (base32 "109hbfk63dh14fz20ivq20gcclb9jj9jmh48w4lcn6zxh1ljh9gi"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; no test suite
(propagated-inputs
`(("expat" ,expat)
("zlib" ,zlib)))
- (native-inputs
- `(("intltool" ,intltool)))
(home-page "https://www.exiv2.org/")
(synopsis "Library and command-line utility to manage image metadata")
(description