summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-28 21:39:50 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-29 11:03:16 +0100
commit14138912501152d0b81775c96852dbc782f0f864 (patch)
tree0d4125f8b3fb6a990e47f2b7a86482db3be9c964 /gnu/packages/image.scm
parent170c6b03444b1bb059728efc85e14edd3688dfdb (diff)
downloadguix-patches-14138912501152d0b81775c96852dbc782f0f864.tar
guix-patches-14138912501152d0b81775c96852dbc782f0f864.tar.gz
gnu: Add icoutils.
* gnu/packages/image.scm (icoutils): New variable.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm38
1 files changed, 36 insertions, 2 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 106b733673..4c9a7f6409 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 ng0 <ng0@n0.is>
-;;; Copyright © 2017,2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2017,2019,2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
@@ -69,10 +69,11 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages sphinx)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
- #:use-module (gnu packages qt)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -1900,3 +1901,36 @@ losslessly translates between SNG and PNG.")
no dependency or linkage required. It's made for C (ISO C90), and has a C++
wrapper with a more convenient interface on top.")
(license license:zlib))))
+
+(define-public icoutils
+ (package
+ (name "icoutils")
+ (version "0.32.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://savannah/icoutils/icoutils-" version ".tar.bz2"))
+ (sha256
+ (base32 "1q66cksms4l62y0wizb8vfavhmf7kyfgcfkynil3n99s0hny1aqp"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libpng" ,libpng)
+ ("perl" ,perl)))
+ (propagated-inputs
+ `(("perl-libwww" ,perl-libwww)))
+ (home-page "https://www.nongnu.org/icoutils/")
+ (synopsis "Extract and convert bitmaps from Windows icon and cursor files")
+ (description "Icoutils are a set of program for extracting and converting
+bitmaps from Microsoft Windows icon and cursor files. These files usually
+have the extension @code{.ico} or @code{.cur}, but they can also be embedded
+in executables and libraries (@code{.dll}-files). (Such embedded files are
+referred to as resources.)
+
+Conversion of these files to and from PNG images is done @command{icotool}.
+@command{extresso} automates these tasks with the help of special resource
+scripts. Resources such can be extracted from MS Windows executable and
+library files with @command{wrestool}.
+
+This package can be used to create @code{favicon.ico} files for web sites.")
+ (license license:gpl3+)))