summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-10-14 00:01:12 +0200
committerMarius Bakke <marius@gnu.org>2021-10-14 00:01:12 +0200
commit0f77e50139b023cb1a5a82ac3a0b9b7fa990c45b (patch)
tree8796bb011e021bf01fe5cb15c70641ee0c0ed5f0 /gnu/packages/image.scm
parent641b31de5e9716ff8bd088f4834c98d4a664b55a (diff)
parent1961b28445080c7b9fb8bf5291ac9a814303522a (diff)
downloadguix-patches-0f77e50139b023cb1a5a82ac3a0b9b7fa990c45b.tar
guix-patches-0f77e50139b023cb1a5a82ac3a0b9b7fa990c45b.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 2dd64d7c4c..99852fc205 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2021 Alexandr Vityazev <avityazev@posteo.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -91,6 +92,7 @@
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages fonts)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -1868,7 +1870,7 @@ Features:
(define-public swappy
(package
(name "swappy")
- (version "1.2.1")
+ (version "1.4.0")
(source
(origin
(method git-fetch)
@@ -1877,7 +1879,7 @@ Features:
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "14ac2jmnak7avcz0jhqjm30vk7pv3gq5aq5rdyh84k8c613kkicf"))))
+ (base32 "1s2lp3bz30svqdg6467jvncim0qgl0q1b1nqxnnci6kljbp5g0xh"))))
(build-system meson-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -1886,6 +1888,9 @@ Features:
(inputs
`(("gtk+" ,gtk+)
("libnotify" ,libnotify)))
+ (propagated-inputs
+ ;; Needed to properly render the icons.
+ `(("font-awesome" ,font-awesome)))
(home-page "https://github.com/jtheoof/swappy")
(synopsis "Grab and edit on the fly snapshots of a Wayland compositor")
(description