summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-09 10:48:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-09 10:52:41 +0200
commit0e289672503a4e1599ef826d49f2fa5575081942 (patch)
treecdaec28207956090b7cebff805135754dcb22f06 /gnu/packages/image.scm
parent0109b89c5834b5374f248dc3681702180013f41f (diff)
parent6df4d8338d2bf94ab729e3b12e42ace0a06687ae (diff)
downloadguix-patches-0e289672503a4e1599ef826d49f2fa5575081942.tar
guix-patches-0e289672503a4e1599ef826d49f2fa5575081942.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 08a9f86be6..2223bfd391 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1595,3 +1595,29 @@ identical visual appearance.")
(description "grim can create screenshots from a Wayland compositor.")
;; MIT license.
(license license:expat)))
+
+(define-public slurp
+ (package
+ (name "slurp")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/slurp.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03igv8r8n772xb0y7whhs1pa298l3d94jbnknaxpwp2n4fi04syb"))))
+ (build-system meson-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("cairo" ,cairo)
+ ("scdoc" ,scdoc)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
+ (home-page "https://github.com/emersion/slurp")
+ (synopsis "Select a region in a Wayland compositor")
+ (description "Slurp can select a region in a Wayland compositor and print it
+to the standard output. It works well together with grim.")
+ ;; MIT license.
+ (license license:expat)))