summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-03-26 09:54:46 +0200
committerLudovic Courtès <ludo@gnu.org>2018-03-26 09:54:46 +0200
commite784e2561ea54ee9301a8ced005ada9a15e1f93c (patch)
treeb5bb0ea0ba863827037fd6f2e5136319f3671bd5 /gnu/packages/image-viewers.scm
parent6ae0fd212accf18c6fff3e32fe52c5a754a17a2a (diff)
downloadguix-patches-e784e2561ea54ee9301a8ced005ada9a15e1f93c.tar
guix-patches-e784e2561ea54ee9301a8ced005ada9a15e1f93c.tar.gz
gnu: geeqie: Update to 1.4.
* gnu/packages/image-viewers.scm (geeqie): Update to 1.4. [arguments]: In 'autogen' phase, create ChangeLog{,.html}.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 7e7e7e3812..ae7ae0f519 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
@@ -105,7 +105,7 @@ actions.")
(define-public geeqie
(package
(name "geeqie")
- (version "1.3")
+ (version "1.4")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/BestImageViewer/geeqie/"
@@ -113,7 +113,7 @@ actions.")
version ".tar.xz"))
(sha256
(base32
- "0gzc82sy66pbsmq7lnmq4y37zqad1zfwfls3ik3dmfm8s5nmcvsb"))))
+ "0ciygvcxb78pqg59r6p061mkbpvkgv2rv3r79j3kgv3kalb3ln2w"))))
(build-system gnu-build-system)
(arguments
`(;; Enable support for a "map" pane using GPS data.
@@ -123,7 +123,18 @@ actions.")
(modify-phases %standard-phases
(add-after 'unpack 'autogen
(lambda _
+ (define (write-dummy-changelog port)
+ (display "See Git history for a change log.\n" port))
+
(setenv "NOCONFIGURE" "true")
+
+ ;; Create ChangeLog{,.html} to placate the makefile, which would
+ ;; otherwise require access to the Git repo.
+ (call-with-output-file "ChangeLog"
+ write-dummy-changelog)
+ (call-with-output-file "ChangeLog.html"
+ write-dummy-changelog)
+
(zero? (system* "sh" "autogen.sh")))))))
(inputs
`(("clutter" ,clutter)