summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-12-02 12:37:04 +0300
committerAlex Kost <alezost@gmail.com>2016-12-04 17:42:05 +0300
commitd1a5b20081c30da7503201df260cf20b8d0ba633 (patch)
tree4914f643001c2c0317bf597918000650bb419542 /gnu/packages/image-viewers.scm
parent023f0fb06ee8dd55f95ff1be542e805363535b97 (diff)
downloadguix-patches-d1a5b20081c30da7503201df260cf20b8d0ba633.tar
guix-patches-d1a5b20081c30da7503201df260cf20b8d0ba633.tar.gz
gnu: Move image viewers to (gnu packages image-viewers).
* gnu/packages/feh.scm (feh): Remove file. Move package to... * gnu/packages/geeqie.scm (geeqie): Likewise... * gnu/packages/sxiv.scm (sxiv): Likewise... * gnu/packages/image-viewers.scm: ... here. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove files.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm130
1 files changed, 129 insertions, 1 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index eb25c11fd4..11cead6b36 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -1,5 +1,11 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
+;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
+;;; This file is part of GNU Guix.
+;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
@@ -20,11 +26,133 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages photo)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xorg))
+
+(define-public feh
+ (package
+ (name "feh")
+ (version "2.14.1")
+ (home-page "https://feh.finalrewind.org/")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append home-page
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1hlzgr0masgbm1vdn085vz81s9kpnah8kjkb1w1xfsxr1b99x8f0"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (alist-delete 'configure %standard-phases)
+ #:tests? #f
+ #:make-flags
+ (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+ (inputs `(("imlib2" ,imlib2)
+ ("curl" ,curl)
+ ("libpng" ,libpng)
+ ("libxt" ,libxt)
+ ("libx11" ,libx11)
+ ("libxinerama" ,libxinerama)))
+ (synopsis "Fast and light imlib2-based image viewer")
+ (description
+ "feh is an X11 image viewer aimed mostly at console users.
+Unlike most other viewers, it does not have a fancy GUI, but simply
+displays images. It can also be used to set the desktop wallpaper.
+It is controlled via commandline arguments and configurable key/mouse
+actions.")
+
+ ;; The license is really the Expat license, with additional wording in the
+ ;; 2nd paragraph: "acknowledgment shall be given in the documentation and
+ ;; software packages that this Software was used."
+ (license (license:x11-style
+ "file://COPYING"
+ "See 'COPYING' in the distribution."))))
+
+(define-public geeqie
+ (package
+ (name "geeqie")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/BestImageViewer/geeqie/"
+ "releases/download/v" version "/geeqie-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0gzc82sy66pbsmq7lnmq4y37zqad1zfwfls3ik3dmfm8s5nmcvsb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autogen
+ (lambda _
+ (setenv "NOCONFIGURE" "true")
+ (zero? (system* "sh" "autogen.sh")))))))
+ (inputs
+ `(;; ("libchamplain" ,libchamplain)
+ ("lcms" ,lcms)
+ ("exiv2" ,exiv2)
+ ("libpng" ,libpng)
+ ("gtk+" ,gtk+-2)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("glib" ,glib "bin") ; glib-gettextize
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://www.geeqie.org/")
+ (synopsis "Lightweight GTK+ based image viewer")
+ (description
+ "Geeqie is a lightweight GTK+ based image viewer for Unix like operating
+systems. It features: EXIF, IPTC and XMP metadata browsing and editing
+interoperability; easy integration with other software; geeqie works on files
+and directories, there is no need to import images; fast preview for many raw
+image formats; tools for image comparison, sorting and managing photo
+collection. Geeqie was initially based on GQview.")
+ (license license:gpl2+)))
+
+(define-public sxiv
+ (package
+ (name "sxiv")
+ (version "1.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/muennich/sxiv/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0lxnd33gaw4drhdwbkk94wzrjyhh64d57jq2ps7ffmqgizg6hlwz"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:make-flags (list (string-append "PREFIX=" %output)
+ "CC=gcc")
+ #:phases (alist-delete
+ 'configure ; no configure phase
+ %standard-phases)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("imlib2" ,imlib2)
+ ("giflib" ,giflib)
+ ("libexif" ,libexif)))
+ (home-page "https://github.com/muennich/sxiv")
+ (synopsis "Simple X Image Viewer")
+ (description
+ "sxiv is an alternative to feh and qiv. Its primary goal is to
+provide the most basic features required for fast image viewing. It has
+vi key bindings and works nicely with tiling window managers. Its code
+base should be kept small and clean to make it easy for you to dig into
+it and customize it for your needs.")
+ (license license:gpl2+)))
(define-public viewnior
(package