summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authordissent <disseminatedissent@protonmail.com>2021-12-05 12:27:02 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-05 12:27:02 +0100
commitc663d037aa3f410706e110ce30b3e07c3edc2870 (patch)
treeb327d6faed9697ab974a92871ebd5bb7eb2db48e /gnu/packages/image-viewers.scm
parent66a2d3830cb6f8cd911dc3847b9ca82b5fddf62e (diff)
downloadguix-patches-c663d037aa3f410706e110ce30b3e07c3edc2870.tar
guix-patches-c663d037aa3f410706e110ce30b3e07c3edc2870.tar.gz
gnu: Add pqiv.
* gnu/packages/image-viewers.scm (pqiv): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 7520d0731a..291dcd383d 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 dissent <disseminatedissent@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -49,6 +50,7 @@
#:use-module (guix build-system python)
#:use-module (gnu packages autotools)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages backup)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages boost)
@@ -72,6 +74,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages maths)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages photo)
@@ -924,6 +927,49 @@ rotate left/right, jump/forward/backward images, filename filter and use it
to set X desktop background.")
(license license:gpl2)))
+(define-public pqiv
+ (package
+ (name "pqiv")
+ (version "2.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phillipberndt/pqiv")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18nvrqmlifh4m8nfs0d19sb9d1l3a95xc89qxqdr881jcxdsgflw"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("gtk+" ,gtk+)
+ ("imagemagick" ,imagemagick)
+ ("libarchive" ,libarchive)
+ ("libspectre" ,libspectre)
+ ("libwebp" ,libwebp)
+ ("poppler" ,poppler)))
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ;no configure script
+ #:make-flags
+ (list
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target))
+ (string-append "PKG_CONFIG=" ,(pkg-config-for-target)))))
+ (home-page "https://www.pberndt.com/Programme/Linux/pqiv")
+ (synopsis "Powerful image viewer with minimal UI")
+ (description
+ "pqiv is a GTK-3 based command-line image viewer with a minimal UI.
+It is highly customizable, can be fully controlled from scripts, and has
+support for various file formats including PDF, Postscript, video files and
+archives.")
+ (license license:gpl3+)))
+
(define-public nomacs
(package
(name "nomacs")