summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-03-18 15:28:47 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-18 16:03:34 +0100
commita6de0c4c9c3f6642fbf653b1c202a39f53da40e5 (patch)
tree0d1d9664d98cf89775f971cc4c195f94bae08857 /gnu/packages/image-viewers.scm
parent7f9616717ffc75eba7b9278f3f31f10d17529fd3 (diff)
downloadguix-patches-a6de0c4c9c3f6642fbf653b1c202a39f53da40e5.tar
guix-patches-a6de0c4c9c3f6642fbf653b1c202a39f53da40e5.tar.gz
gnu: feh, newsboat: Inline top-level reference to 'curl'.
These references introduced top-level circular dependencies. Furthermore, they were inaccurate since only CURL_CA_BUNDLE is honored. * gnu/packages/image-viewers.scm (feh)[native-search-paths]: Remove top-level reference to 'curl'; inline "CURL_CA_BUNDLE" spec. * gnu/packages/syndication.scm (newsboat)[native-search-paths]: Likewise.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 6c5d70032d..6ab6cf3307 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -287,7 +287,11 @@ YouTube videos without requiring API and opens/downloads them using mpv/ytdl.")
(native-search-paths
;; Feh allows overriding the libcurl builtin CA path (unset in Guix)
;; with the same variable as the `curl` command line HTTP tool.
- (package-native-search-paths curl))
+ (list (search-path-specification
+ (variable "CURL_CA_BUNDLE")
+ (file-type 'regular)
+ (separator #f) ;single entry
+ (files '("etc/ssl/certs/ca-certificates.crt")))))
(synopsis "Fast and light imlib2-based image viewer")
(description
"feh is an X11 image viewer aimed mostly at console users.