summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/image-viewers.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm37
1 files changed, 20 insertions, 17 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index de83084cdc..dc23420ad9 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -81,6 +82,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages suckless)
#:use-module (gnu packages terminals)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
@@ -250,7 +252,7 @@ YouTube videos without requiring API and opens/downloads them using mpv/ytdl.")
(define-public feh
(package
(name "feh")
- (version "3.7.1")
+ (version "3.7.2")
(home-page "https://feh.finalrewind.org/")
(source (origin
(method url-fetch)
@@ -258,7 +260,7 @@ YouTube videos without requiring API and opens/downloads them using mpv/ytdl.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "1djqjagp7k9rris1p8wgz0q8albgsd8gasc0hyanbjap3yk1rasp"))))
+ "0n42kj18ldlcmrmk5qir9gs9irdl1vz9913n8p941x8cfb98ywc4"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases (delete 'configure))
@@ -740,7 +742,7 @@ displayed in a terminal.")
(define-public imv
(package
(name "imv")
- (version "4.1.0")
+ (version "4.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -748,13 +750,12 @@ displayed in a terminal.")
(commit (string-append "v" version))))
(sha256
(base32
- "0gk8g178i961nn3bls75a8qpv6wvfvav6hd9lxca1skaikd33zdx"))
+ "12xcayyzmfknbff04z8jdlxsnnimgisqiah0bw07cyxx8ksmdzqw"))
(file-name (git-file-name name version))))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (delete 'configure)
(add-after 'install 'record-absolute-file-names
(lambda* (#:key outputs #:allow-other-keys)
;; 'imv' is a script that execs 'imv-x11' or 'imv-wayland'.
@@ -764,22 +765,24 @@ displayed in a terminal.")
(substitute* (string-append bin "/imv")
(("imv-")
(string-append bin "/imv-")))
- #t))))
- #:make-flags
- (list ,(string-append "CC=" (cc-for-target))
- (string-append "PREFIX=" (assoc-ref %outputs "out"))
- (string-append "CONFIGPREFIX="
- (assoc-ref %outputs "out") "/etc"))))
+ #t))))))
(inputs
- `(("asciidoc" ,asciidoc)
- ("freeimage" ,freeimage)
+ `(("freeimage" ,freeimage)
("glu" ,glu)
- ("librsvg" ,librsvg)
+ ("libheif" ,libheif)
+ ("libjpeg-turbo" ,libjpeg-turbo)
+ ("libinih" ,libinih)
+ ("libnsgif" ,libnsgif)
+ ("librsvg" ,librsvg-next)
+ ("libtiff" ,libtiff)
("libxkbcommon" ,libxkbcommon)
("pango" ,pango)
("wayland" ,wayland)))
(native-inputs
- `(("cmocka" ,cmocka)
+ `(("asciidoc" ,asciidoc)
+ ("cmocka" ,cmocka)
+ ;; why build need it?
+ ("git" ,git-minimal)
("pkg-config" ,pkg-config)))
(synopsis "Image viewer for tiling window managers")
(description "@code{imv} is a command line image viewer intended for use
@@ -904,7 +907,7 @@ to set X desktop background.")
("libtiff" ,libtiff)
("opencv" ,opencv)
("python" ,python-wrapper)
- ("quazip" ,quazip)
+ ("quazip" ,quazip-0)
("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)))
(native-inputs