summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-12 00:08:23 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-12 00:09:14 -0500
commit95633a36b224893cca061705560a8e96e3c2c870 (patch)
treeb74440cac1c02650085840811ad16c24041cb2f3 /gnu/packages/image-viewers.scm
parentf250004bf992ae267ad6db2361eb174975f8c7d9 (diff)
downloadguix-patches-95633a36b224893cca061705560a8e96e3c2c870.tar
guix-patches-95633a36b224893cca061705560a8e96e3c2c870.tar.gz
gnu: geeqie: Update to 1.6.
* gnu/packages/image-viewers.scm (geeqie): Update to 1.6. [phases]{correctly-locate-aux-scripts}: New phase.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm27
1 files changed, 21 insertions, 6 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 7051bd5dc6..32585aa06b 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -302,7 +302,7 @@ actions.")
(define-public geeqie
(package
(name "geeqie")
- (version "1.5")
+ (version "1.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -310,14 +310,29 @@ actions.")
(commit (string-append "v" version))))
(sha256
(base32
- "0nf45sh3pwsv98sppcrqj81b6mdi31n1sbc7gn88m8mhpfp1qq6k"))
+ "1i9yd8lddp6b9s9vjjjzbpqj4bvwidxc6kiba6vdrk7dda5akyky"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `( ;; Enable support for a "map" pane using GPS data.
- #:configure-flags '("CFLAGS=-fcommon"
+ ;; Enable support for a "map" pane using GPS data.
+ `(#:configure-flags '("CFLAGS=-fcommon"
"--enable-map"
- "--enable-gtk3")))
+ "--enable-gtk3")
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'correctly-locate-aux-scripts
+ ;; The git checkout has symlinks under the auxdir
+ ;; directory pointing to /usr/share/automake-1.16/depcomp
+ ;; and /usr/share/automake-1.16/install-sh, which causes
+ ;; the configure phase to fail (see:
+ ;; https://github.com/BestImageViewer/geeqie/issues/936).
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((automake (assoc-ref inputs "automake")))
+ (delete-file "auxdir/depcomp")
+ (symlink (car (find-files automake "depcomp"))
+ "auxdir/depcomp")
+ (delete-file "auxdir/install-sh")
+ (symlink (car (find-files automake "install-sh"))
+ "auxdir/install-sh")))))))
(inputs
`(("clutter" ,clutter)
("libchamplain" ,libchamplain)
@@ -328,7 +343,7 @@ actions.")
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("glib" ,glib "bin") ; glib-gettextize
+ ("glib" ,glib "bin") ; glib-gettextize
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(home-page "http://www.geeqie.org/")