summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-17 22:04:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-17 22:55:04 -0400
commit8d60951864aea62440fb0de70ec6739bd3dcc594 (patch)
tree5bcb2b9bc029dd75bc5f30a5ce2ef7b653ecbe01 /gnu/packages/image-viewers.scm
parente3af0324bce0b1f1ba0732e2d571db9e61154f75 (diff)
downloadguix-patches-8d60951864aea62440fb0de70ec6739bd3dcc594.tar
guix-patches-8d60951864aea62440fb0de70ec6739bd3dcc594.tar.gz
gnu: viewnior: Use new style inputs and fix indentation.
* gnu/packages/image-viewers.scm (viewnior)[phases]: Delete trailing #t. [native-inputs, inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm47
1 files changed, 23 insertions, 24 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 3ab450dec6..52c9584f67 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 dissent <disseminatedissent@protonmail.com>
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -412,34 +413,32 @@ needs.")
(name "viewnior")
(version "1.8")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hellosiyan/Viewnior")
- (commit (string-append name "-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "14qvx1wajncd5ab0207274cwk32f4ipfnlaci6phmah0cwra2did"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hellosiyan/Viewnior")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14qvx1wajncd5ab0207274cwk32f4ipfnlaci6phmah0cwra2did"))))
(build-system meson-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-source
- (lambda _
- ;; Don't create 'icon-theme.cache'
- (substitute* "meson.build"
- (("meson.add_install_script*") ""))
- #t)))
- #:tests? #f)) ; no tests
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ ;; Don't create 'icon-theme.cache'
+ (substitute* "meson.build"
+ (("meson.add_install_script*") "")))))
+ #:tests? #f)) ;no tests
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib" ,glib "bin") ; glib-genmarshal
- ("pkg-config" ,pkg-config)
- ("shared-mime-info" ,shared-mime-info)))
+ (list gettext-minimal
+ `(,glib "bin") ;glib-genmarshal
+ pkg-config
+ shared-mime-info))
(inputs
- `(("exiv2" ,exiv2)
- ("gdk-pixbuf" ,gdk-pixbuf)
- ("gtk+-2" ,gtk+-2)))
+ (list exiv2
+ gdk-pixbuf
+ gtk+-2))
(home-page "https://siyanpanayotov.com/project/viewnior")
(synopsis "Simple, fast and elegant image viewer")
(description "Viewnior is an image viewer program. Created to be simple,