summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-17 05:40:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-17 17:12:48 +0100
commit6420cab3413e13d38a0a768d8227ba82071ab554 (patch)
tree120bdc88c3f359916f92fe94a527c117deb1a90e /gnu/packages/image-viewers.scm
parent7969789efe964fe715371e4acee6a915d4987c02 (diff)
downloadguix-patches-6420cab3413e13d38a0a768d8227ba82071ab554.tar
guix-patches-6420cab3413e13d38a0a768d8227ba82071ab554.tar.gz
gnu: sxiv: Update to 26.
* gnu/packages/image-viewers.scm (sxiv): Update to 26.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 85d3a153e7..989deb1707 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 nee <nee-git@hidamari.blue>
-;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
@@ -216,7 +216,7 @@ It is the default image viewer on LXDE desktop environment.")
(define-public sxiv
(package
(name "sxiv")
- (version "25")
+ (version "26")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -225,15 +225,15 @@ It is the default image viewer on LXDE desktop environment.")
(file-name (git-file-name name version))
(sha256
(base32
- "13s1lfar142hq1j7xld0ri616p4bqs57b17yr4d0b9a9w7liz4hp"))))
+ "0xaawlfdy7b277m38mgg4423kd7p1ffn0dq4hciqs6ivbb3q9c4f"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
#:make-flags
(list (string-append "PREFIX=" %output)
"CC=gcc"
- ;; Xft.h #includes <ft2build.h> (without ‘freetype2/’). The sxiv
- ;; Makefile works around this by hard-coding /usr/include instead.
+ ;; Xft.h #includes <ft2build.h> without ‘freetype2/’. The Makefile
+ ;; works around this by hard-coding /usr/include & $PREFIX.
(string-append "CPPFLAGS=-I"
(assoc-ref %build-inputs "freetype")
"/include/freetype2")