summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-05-13 20:23:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-05-13 20:24:40 +0300
commit307cdd665ec216dff4b4209b14ccc6f44778f581 (patch)
tree9589d44534b8fbdecb80d40de96d37512a90b539 /gnu/packages/image-viewers.scm
parente42c3649d867de0cfabae0a234187679f5736030 (diff)
downloadguix-patches-307cdd665ec216dff4b4209b14ccc6f44778f581.tar
guix-patches-307cdd665ec216dff4b4209b14ccc6f44778f581.tar.gz
gnu: viewnior: Update to 1.7.
* gnu/packages/image-viewers.scm (viewnior): Update to 1.7. [source]: Update source uri. [build-system]: Switch to meson-build-system. [arguments]: Remove custom 'autogen and 'skip-gtk-update-icon-cache phases, add 'patch-source phase. Skip tests. [native-inputs]: Remove automake, autoconf, intltool, gnome-common, libtool, which, add gettext-minimal. [home-page]: Update home-page.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm36
1 files changed, 15 insertions, 21 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 1f0a9e46e1..8d60dc0674 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -31,14 +31,15 @@
#:use-module (guix packages)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (gnu packages autotools)
#:use-module (gnu packages algebra)
- #:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -231,43 +232,36 @@ it and customize it for your needs.")
(define-public viewnior
(package
(name "viewnior")
- (version "1.6")
+ (version "1.7")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/xsisqox/Viewnior/archive/"
+ (uri (string-append "https://github.com/hellosiyan/Viewnior/archive/"
name "-" version ".tar.gz"))
(sha256
(base32
- "18309qjgwak3kn228z3p3nx7yxasqgzx69v3rgc23hf161nky0c9"))))
- (build-system gnu-build-system)
+ "1rpkk721s3xas125q3g0fl11b5zsrmzv9pzl6ddzcy4sj2rd7ymr"))))
+ (build-system meson-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autogen
- (lambda _
- (zero? (system* "sh" "autogen.sh"))))
- (add-before 'install 'skip-gtk-update-icon-cache
+ (add-after 'unpack 'patch-source
(lambda _
;; Don't create 'icon-theme.cache'
- (substitute* (find-files "data" "^Makefile$")
- (("gtk-update-icon-cache") (which "true")))
- #t)))))
+ (substitute* "meson.build"
+ (("meson.add_install_script*") ""))
+ #t)))
+ #:tests? #f)) ; no tests
(native-inputs
- `(("automake" ,automake)
- ("autoconf" ,autoconf)
- ("intltool" ,intltool)
+ `(("gettext" ,gettext-minimal)
("glib" ,glib "bin") ; glib-genmarshal
- ("gnome-common" ,gnome-common)
- ("libtool" ,libtool)
("pkg-config" ,pkg-config)
- ("shared-mime-info" ,shared-mime-info)
- ("which" ,which)))
+ ("shared-mime-info" ,shared-mime-info)))
(inputs
`(("exiv2" ,exiv2)
("gdk-pixbuf" ,gdk-pixbuf)
("gtk+-2" ,gtk+-2)))
- (home-page "http://siyanpanayotov.com/project/viewnior/")
+ (home-page "http://siyanpanayotov.com/project/viewnior")
(synopsis "Simple, fast and elegant image viewer")
(description "Viewnior is an image viewer program. Created to be simple,
fast and elegant. Its minimalistic interface provides more screenspace for