summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-03-05 22:46:42 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-08 00:06:43 +0100
commit2fa624ddd16c3a8c6180b441c8e9f520816225f6 (patch)
tree0f5146167a52fd24627c1a5e758442413a7fc352 /gnu/packages/image-viewers.scm
parent387cac30bc4161055aba0c51e798a440f44592c2 (diff)
downloadguix-patches-2fa624ddd16c3a8c6180b441c8e9f520816225f6.tar
guix-patches-2fa624ddd16c3a8c6180b441c8e9f520816225f6.tar.gz
gnu: Add xzgv.
* gnu/packages/image-viewers.scm (xzgv): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index bddf86568c..b7c1ebc829 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2021 Rovanion Luckey <rovanion.luckey@gmail.com>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -748,3 +749,40 @@ allows creating false color images. A unique feature of Nomacs is the
synchronization of multiple instances.")
(home-page "https://nomacs.org/")
(license license:gpl3+)))
+
+(define-public xzgv
+ (package
+ (name "xzgv")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/xzgv/"
+ version "/xzgv-" version ".tar.gz"))
+ (sha256
+ (base32 "17l1xr9v07ggwga3vn0z1i4lnwjrr20rr8z1kjbw71aaijxl18i5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-target-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "config.mk"
+ (("/usr/local") (assoc-ref outputs "out")))))
+ (delete 'configure) ; no configure script
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "src/xzgv" bin))))) ; just install the executable
+ #:tests? #f)) ; no rule for target 'test'
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+-2)
+ ("libexif" ,libexif)))
+ (home-page "https://sourceforge.net/projects/xzgv/")
+ (synopsis "Picture viewer for X with a thumbnail-based selector")
+ (description
+ "xzgv is a fast image viewer that provides extensive keyboard support.")
+ (license license:gpl2+)))