summaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2020-09-17 19:09:21 +1000
committerMathieu Othacehe <othacehe@gnu.org>2020-10-01 14:22:15 +0200
commita76e9d13e9b5cad2bbfc0433d2f8d0eae2af0b05 (patch)
treec69089ae0b1d876b99bb8b2639bedb93c9c3d2ec /gnu/packages/image-processing.scm
parente74818353882f187e5971b5a3a481f17df883dbe (diff)
downloadguix-patches-a76e9d13e9b5cad2bbfc0433d2f8d0eae2af0b05.tar
guix-patches-a76e9d13e9b5cad2bbfc0433d2f8d0eae2af0b05.tar.gz
gnu: Add scantailor-advanced.
* gnu/packages/image-processing.scm (scantailor-advanced): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 2edf2e0cac..e313b14ebf 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +34,7 @@
#:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system qt)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
@@ -1015,3 +1017,50 @@ substituted, as well as collage-style photomosaics, in which rectangular parts
of the source image at arbitrary positions (i.e. not aligned to a matrix) are
substituted by matching images.")
(license license:gpl2))))
+
+(define-public scantailor-advanced
+ (let ((commit "3d1e74e6ace413733511086934a66f4e3f7a6027"))
+ (package
+ (name "scantailor-advanced")
+ (version (string-append "1.0.16-" (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/4lex4/scantailor-advanced")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0kixwjb2x457dq7927hkh34c803p7yh1pmn6n61rk9shqrcg492h"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("boost" ,boost)
+ ("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Some tests require a display and fail with offscreen mode.
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (setenv "ARGS" "--exclude-regex \"imageproc_.*\"")
+ #t)))))
+ (home-page "https://github.com/4lex4/scantailor-advanced")
+ (synopsis "Clean up scanned pages")
+ (description "Scan Tailor is an interactive post-processing tool for
+scanned pages. It performs operations such as page splitting, deskewing,
+adding/removing borders, and others. You give it raw scans, and you get pages
+ready to be printed or assembled into a PDF or DJVU file. Scanning, optical
+character recognition, and assembling multi-page documents are out of scope of
+this project.
+
+Scan Tailer Advanced is a fork of Scan Tailer that merges Scan Tailor Featured
+and Scan Tailor Enhanced versions as well as including many more bug fixes.")
+ (license license:gpl3+))))