summaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 23:43:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:06 -0400
commit607e48ba3ccb038e2fa4b956cb62ce628cdc8cd0 (patch)
tree6b802b21618ced9de8bc94bf7cc9f713879d2072 /gnu/packages/image-processing.scm
parent17375266ea2e94726bf3d28c1d4fb3899c115377 (diff)
downloadguix-patches-607e48ba3ccb038e2fa4b956cb62ce628cdc8cd0.tar
guix-patches-607e48ba3ccb038e2fa4b956cb62ce628cdc8cd0.tar.gz
gnu: Add vtk-7.
* gnu/packages/image-processing.scm: (vtk-7): New variable. * gnu/packages/patches/vtk-7-gcc-10-compat.patch: New patch. * gnu/packages/patches/vtk-7-hdf5-compat.patch: Likewise. * gnu/packages/patches/vtk-7-python-compat.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them.
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 1995f71cc2..08aeaed202 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -407,6 +407,28 @@ a suite of 3D interaction widgets, supports parallel processing, and
integrates with various databases on GUI toolkits such as Qt and Tk.")
(license license:bsd-3)))
+(define-public vtk-7
+ (package
+ (inherit vtk)
+ (version "7.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://vtk.org/files/release/"
+ (version-major+minor version)
+ "/VTK-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0nm7xwwj7rnsxjdv2ssviys8nhci4n9iiiqm2y14s520hl2dsp1d"))
+ (patches (search-patches "vtk-7-python-compat.patch"
+ "vtk-7-hdf5-compat.patch"
+ "vtk-7-gcc-10-compat.patch"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments vtk)
+ ((#:configure-flags flags)
+ ;; Otherwise, the build would fail with: "error: invalid conversion
+ ;; from ‘const char*’ to ‘char*’ [-fpermissive]".
+ `(cons "-DCMAKE_CXX_FLAGS=-fpermissive" ,flags))))))
+
;; itksnap needs an older variant of VTK.
(define-public vtk-6
(package (inherit vtk)