summaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorTomasz Jeneralczyk <tj@schwi.pl>2022-08-14 14:46:21 +0200
committerLudovic Courtès <ludo@gnu.org>2022-08-30 00:40:05 +0200
commit5920196e47343403ea43f49c19b637fe62a11220 (patch)
treeceaacad350d8d9952633adf8367208b45a9984b1 /gnu/packages/image-processing.scm
parent619af9f3076fbfb29f4c44e38a74bc1c5808624c (diff)
downloadguix-patches-5920196e47343403ea43f49c19b637fe62a11220.tar
guix-patches-5920196e47343403ea43f49c19b637fe62a11220.tar.gz
gnu: opencv: Build Python bindings.
* gnu/packages/image-processing.scm (opencv)[arguments]: Change variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 3dfe086af8..0225f72651 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -511,6 +512,9 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
;; DISPATCH is the list of optional dispatches.
"-DCPU_BASELINE=SSE2"
+ ;; Build Python bindings.
+ "-DBUILD_opencv_python3=ON"
+
,@(match (%current-system)
("x86_64-linux"
'("-DCPU_DISPATCH=NEON;VFPV3;FP16;SSE;SSE2;SSE3;SSSE3;SSE4_1;SSE4_2;POPCNT;AVX;FP16;AVX2;FMA3;AVX_512F;AVX512_SKX"