summaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorOleh Malyi <astroclubzp@gmail.com>2021-01-05 00:23:38 +0000
committerLeo Famulari <leo@famulari.name>2021-01-04 20:48:20 -0500
commit58a5746e7361c317e352920745fbe2ad01e2e802 (patch)
tree0729ad2fa5e5aad3be245f314fcff080c153987d /gnu/packages/image-processing.scm
parentf40ddf95a34944673cd6262b7aae0c643e653ff9 (diff)
downloadguix-patches-58a5746e7361c317e352920745fbe2ad01e2e802.tar
guix-patches-58a5746e7361c317e352920745fbe2ad01e2e802.tar.gz
gnu: Add stiff.
* gnu/packages/image-processing.scm (stiff): New variable. Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 8d31029963..388e91d31a 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021 Oleh Malyi <astroclubzp@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1064,3 +1065,27 @@ this project.
Scan Tailer Advanced is a fork of Scan Tailer that merges Scan Tailor Featured
and Scan Tailor Enhanced versions as well as including many more bug fixes.")
(license license:gpl3+))))
+
+(define-public stiff
+ (package
+ (name "stiff")
+ (version "2.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.astromatic.net/download/stiff/stiff-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "14m92dskzw7bwsr64ha4p0mj3ndv13gwcbfic3qxrs3zq5353s7l"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libtiff" ,libtiff)
+ ("zlib" ,zlib)
+ ("libjpeg-turbo" ,libjpeg-turbo)))
+ (home-page "https://www.astromatic.net/software/stiff")
+ (synopsis "Convert scientific FITS images to TIFF format")
+ (description
+ "STIFF is a program that converts scientific @acronym{FITS, Flexible Image
+Transport System} images to the more popular TIFF format for illustration
+purposes.")
+ (license license:gpl3+)))