summaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 11:47:19 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:07 -0400
commit54ef40a1f79d6d636ba26ac47f6dd0b84172dd0d (patch)
tree33829e6f0a5069b6c78b22c5f5dd78479c4ae04f /gnu/packages/image-processing.scm
parent672eab90bbeb16e51322505739b14de6a8f1fa6d (diff)
downloadguix-patches-54ef40a1f79d6d636ba26ac47f6dd0b84172dd0d.tar
guix-patches-54ef40a1f79d6d636ba26ac47f6dd0b84172dd0d.tar.gz
gnu: mia: Update to 2.4.7.
* gnu/packages/patches/mia-fix-boost-headers.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/image-processing.scm (mia): Update to 2.4.7. [source]: Apply patch. [configure-flags]: Use the more conventional OFF option value (instead of 0). [inputs]: Use new style. Replace python2-lxml by python-lxml. Replace vtk by vtk-7. [native-inputs]: Use new style. Replace python-2 with python-wrapper.
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm56
1 files changed, 30 insertions, 26 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index e725fe04f7..f4bf1724b4 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -185,7 +185,7 @@ licences similar to the Modified BSD licence."))))
(define-public mia
(package
(name "mia")
- (version "2.4.6")
+ (version "2.4.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/mia/mia/"
@@ -193,37 +193,41 @@ licences similar to the Modified BSD licence."))))
"/mia-" version ".tar.xz"))
(sha256
(base32
- "0j4nd5z7i3v199jh7hqqhwd4g7snchizkc7rhzanpvngqg91m1pb"))))
+ "0qpcd3n26q52dpyibm11f5l6cgscdr54p2jish39gc3p1f5h3ws1"))
+ (patches (search-patches "mia-fix-boost-headers.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
- (list "-DMIA_CREATE_NIPYPE_INTERFACES=0"
+ (list "-DMIA_CREATE_NIPYPE_INTERFACES=OFF"
"-DCMAKE_CXX_FLAGS=-fpermissive")))
(inputs
- `(("boost" ,boost)
- ("dcmtk" ,dcmtk)
- ("doxygen" ,doxygen)
- ("eigen" ,eigen)
- ("fftw" ,fftw)
- ("fftwf" ,fftwf)
- ("gsl" ,gsl)
- ("gts" ,gts)
- ("hdf5" ,hdf5)
- ("itpp" ,itpp)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("libxml" ,libxml2)
- ("libxml++" ,libxml++)
- ("maxflow" ,maxflow)
- ("niftilib" ,niftilib)
- ("nlopt" ,nlopt)
- ("openexr" ,openexr-2)
- ("python-lxml" ,python2-lxml)
- ("vtk" ,vtk)))
+ (list boost
+ dcmtk
+ doxygen
+ eigen
+ fftw
+ fftwf
+ gsl
+ gts
+ hdf5
+ itpp
+ libjpeg-turbo
+ libpng
+ libtiff
+ libxml2
+ libxml++
+ maxflow
+ niftilib
+ nlopt
+ openexr-2
+ python-lxml
+ ;; The build fails when using the regular VTK (currently at version
+ ;; 9), with error "addons/vtk/vtkvf.cc:23:10: fatal error:
+ ;; vtkStructuredPointsReader.h: No such file or directory".
+ vtk-7))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python-2)))
+ (list pkg-config
+ python-wrapper))
(home-page "http://mia.sourceforge.net")
(synopsis "Toolkit for gray scale medical image analysis")
(description "MIA provides a combination of command line tools, plug-ins,