summaryrefslogtreecommitdiff
path: root/gnu/packages/idris.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/idris.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/idris.scm')
-rw-r--r--gnu/packages/idris.scm75
1 files changed, 36 insertions, 39 deletions
diff --git a/gnu/packages/idris.scm b/gnu/packages/idris.scm
index 10ad154923..3e480e06b4 100644
--- a/gnu/packages/idris.scm
+++ b/gnu/packages/idris.scm
@@ -52,41 +52,38 @@
"idris-build-with-megaparsec-9.patch"))))
(build-system haskell-build-system)
(native-inputs ;For tests
- `(("perl" ,perl)
- ("ghc-cheapskate" ,ghc-cheapskate)
- ("ghc-tasty" ,ghc-tasty)
- ("ghc-tasty-golden" ,ghc-tasty-golden)
- ("ghc-tasty-rerun" ,ghc-tasty-rerun)))
+ (list perl ghc-cheapskate ghc-tasty ghc-tasty-golden
+ ghc-tasty-rerun))
(inputs
- `(("gmp" ,gmp)
- ("ncurses" ,ncurses)
- ("ghc-aeson" ,ghc-aeson)
- ("ghc-annotated-wl-pprint" ,ghc-annotated-wl-pprint)
- ("ghc-ansi-terminal" ,ghc-ansi-terminal)
- ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
- ("ghc-async" ,ghc-async)
- ("ghc-base64-bytestring" ,ghc-base64-bytestring)
- ("ghc-blaze-html" ,ghc-blaze-html)
- ("ghc-blaze-markup" ,ghc-blaze-markup)
- ("ghc-cheapskate" ,ghc-cheapskate)
- ("ghc-code-page" ,ghc-code-page)
- ("ghc-fingertree" ,ghc-fingertree)
- ("ghc-fsnotify" ,ghc-fsnotify)
- ("ghc-ieee754" ,ghc-ieee754)
- ("ghc-libffi" ,ghc-libffi)
- ("ghc-megaparsec" ,ghc-megaparsec)
- ("ghc-network" ,ghc-network)
- ("ghc-optparse-applicative" ,ghc-optparse-applicative)
- ("ghc-regex-tdfa" ,ghc-regex-tdfa)
- ("ghc-safe" ,ghc-safe)
- ("ghc-split" ,ghc-split)
- ("ghc-terminal-size" ,ghc-terminal-size)
- ("ghc-uniplate" ,ghc-uniplate)
- ("ghc-unordered-containers" ,ghc-unordered-containers)
- ("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-vector" ,ghc-vector)
- ("ghc-vector-binary-instances" ,ghc-vector-binary-instances)
- ("ghc-zip-archive" ,ghc-zip-archive)))
+ (list gmp
+ ncurses
+ ghc-aeson
+ ghc-annotated-wl-pprint
+ ghc-ansi-terminal
+ ghc-ansi-wl-pprint
+ ghc-async
+ ghc-base64-bytestring
+ ghc-blaze-html
+ ghc-blaze-markup
+ ghc-cheapskate
+ ghc-code-page
+ ghc-fingertree
+ ghc-fsnotify
+ ghc-ieee754
+ ghc-libffi
+ ghc-megaparsec
+ ghc-network
+ ghc-optparse-applicative
+ ghc-regex-tdfa
+ ghc-safe
+ ghc-split
+ ghc-terminal-size
+ ghc-uniplate
+ ghc-unordered-containers
+ ghc-utf8-string
+ ghc-vector
+ ghc-vector-binary-instances
+ ghc-zip-archive))
(arguments
`(#:configure-flags
(list (string-append "--datasubdir="
@@ -214,7 +211,7 @@ Epigram and Agda.")
"1pkxnn3ryr0v0cin4nasw7kgkc9dnnpja1nfbj466mf3qv5s98af"))))
(build-system gnu-build-system)
(native-inputs
- `(("idris" ,idris)))
+ (list idris))
(arguments (idris-default-arguments name))
(home-page "https://github.com/ziman/lightyear")
(synopsis "Lightweight parser combinator library for Idris")
@@ -239,7 +236,7 @@ difference: backtracking.")
"0g7c3y9smifdz4sivi3qmvymhdr7v9kfq45fmfmmvkqcrix0spzn"))))
(build-system gnu-build-system)
(native-inputs
- `(("idris" ,idris)))
+ (list idris))
(arguments (idris-default-arguments name))
(home-page "https://github.com/shayan-najd/wl-pprint")
(synopsis "Pretty printing library")
@@ -264,7 +261,7 @@ wl-pprint library.")
"02vbsd3rmgnj0l1qq787709qcxjbr9890cbad4ykn27f77jk81h4"))))
(build-system gnu-build-system)
(native-inputs
- `(("idris" ,idris)))
+ (list idris))
(arguments (idris-default-arguments name))
(home-page "https://github.com/HuwCampbell/Idris-Bifunctors")
(synopsis "Bifunctor library")
@@ -288,9 +285,9 @@ excellent Haskell Bifunctors package from Edward Kmett.")
"06jzfj6rad08rk92w8jk5byi79svmyg0mrcqhibgx8rkjjy6vmai"))))
(build-system gnu-build-system)
(native-inputs
- `(("idris" ,idris)))
+ (list idris))
(propagated-inputs
- `(("idris-bifunctors" ,idris-bifunctors)))
+ (list idris-bifunctors))
(arguments (idris-default-arguments name))
(home-page "https://github.com/HuwCampbell/idris-lens")
(synopsis "Van Laarhoven lenses for Idris")