summaryrefslogtreecommitdiff
path: root/gnu/packages/idris.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-09-16 22:20:23 -0500
committerEric Bavier <bavier@member.fsf.org>2019-09-24 21:15:24 -0500
commit4780db2c935110ea3254817ba0c519c229b9461e (patch)
treef070e8f3e3d12989feb7a0c4495449ac17f1c4f9 /gnu/packages/idris.scm
parentc463c270dc0e1690d3c7cc19cd78583ce9bf9bd1 (diff)
downloadguix-patches-4780db2c935110ea3254817ba0c519c229b9461e.tar
guix-patches-4780db2c935110ea3254817ba0c519c229b9461e.tar.gz
gnu: idris: Update to 1.3.2.
* gnu/packages/haskell-xyz.scm (ghc-network-2.8, ghc-megaparsec-7): New variables. * gnu/packages/idris.scm (idris): Update to 1.3.2. [source]: Remove patch. [inputs]: Use ghc-network-2.8 and ghc-megaparsec-7. * gnu/packages/patches/idris-test-no-node.patch: Delete. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/idris.scm')
-rw-r--r--gnu/packages/idris.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/idris.scm b/gnu/packages/idris.scm
index 894a19f0aa..7e6ee302b0 100644
--- a/gnu/packages/idris.scm
+++ b/gnu/packages/idris.scm
@@ -38,7 +38,7 @@
(define-public idris
(package
(name "idris")
- (version "1.3.1")
+ (version "1.3.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -46,8 +46,7 @@
"idris-" version "/idris-" version ".tar.gz"))
(sha256
(base32
- "0fn9h58l592j72njwma1ia48h8h87wi2rjqfxs7j2lfmvgfv18fi"))
- (patches (search-patches "idris-test-no-node.patch"))))
+ "0wychzkg0yghd2pp8fqz78vp1ayzks191knfpl7mhh8igsmb6bc7"))))
(build-system haskell-build-system)
(native-inputs ;For tests
`(("perl" ,perl)
@@ -71,8 +70,8 @@
("ghc-fsnotify" ,ghc-fsnotify)
("ghc-ieee754" ,ghc-ieee754)
("ghc-libffi" ,ghc-libffi)
- ("ghc-megaparsec" ,ghc-megaparsec)
- ("ghc-network" ,ghc-network)
+ ("ghc-megaparsec" ,ghc-megaparsec-7)
+ ("ghc-network" ,ghc-network-2.8)
("ghc-optparse-applicative" ,ghc-optparse-applicative)
("ghc-regex-tdfa" ,ghc-regex-tdfa)
("ghc-safe" ,ghc-safe)