summaryrefslogtreecommitdiff
path: root/gnu/packages/icu4c.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-30 03:40:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:01 +0100
commite8acfd1a9fcb5d947f023293852373758784d15f (patch)
tree4b2e1e596edd4afd7c726571a1e8b237600b3d77 /gnu/packages/icu4c.scm
parentd7316c774386a79559d557a5cec7f98e345561c6 (diff)
downloadguix-patches-e8acfd1a9fcb5d947f023293852373758784d15f.tar
guix-patches-e8acfd1a9fcb5d947f023293852373758784d15f.tar.gz
gnu: icu4c: Update to 65.1.
* gnu/packages/icu4c.scm (%icu4c-patches): Remove variable. (icu4c): Update to 65.1. [source](uri): Change to new download location. [source](patches, patch-flags): Remove.
Diffstat (limited to 'gnu/packages/icu4c.scm')
-rw-r--r--gnu/packages/icu4c.scm32
1 files changed, 4 insertions, 28 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index c70871f7e7..717ed277ee 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -33,44 +33,20 @@
#:use-module (guix build-system ant)
#:use-module (guix build-system gnu))
-;; These patches are taken from ICUs 'maint-64' branch and will be included in
-;; 64.3. The latter patch is needed because many packages use "invalid"
-;; locales which misbehave with ICU 64.2. See discussion at
-;; <https://lists.gnu.org/archive/html/guix-devel/2019-07/msg00343.html>.
-(define %icu4c-patches
- (list (origin
- (method url-fetch)
- (uri (string-append "https://github.com/unicode-org/icu/commit/"
- "7788f04eb9be0d7ecade6af46cf7b9825447763d.patch"))
- (file-name "icu4c-datetime-regression.patch")
- (sha256
- (base32
- "0gs2sbdfpzwwdjqcqr0c16fw3g7wy3gb1gbgvzs9k1ciw0bhpv4w")))
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/unicode-org/icu/commit/"
- "cfb20862909ff105d4f2c43923c97561bc5a5815.patch"))
- (file-name "icu4c-locale-mapping.patch")
- (sha256
- (base32
- "0s5psb60aisj6icziblvlp9dqcz56n3887i8ib0yidbjnnrw5b97")))))
-
(define-public icu4c
(package
(name "icu4c")
- (version "64.2")
+ (version "65.1")
(source (origin
(method url-fetch)
(uri (string-append
- "http://download.icu-project.org/files/icu4c/"
- version
+ "https://github.com/unicode-org/icu/releases/download/release-"
+ (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
"/icu4c-"
(string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
"-src.tgz"))
- (patches %icu4c-patches)
- (patch-flags '("-p2"))
(sha256
- (base32 "0v0xsf14xwlj125y9fd8lrhsaych4d8liv8gr746zng6g225szb2"))))
+ (base32 "0j6r6qqnhfr5iqkx53k63ifkm93kv1kkb7h2mlgd1mnnndk79qsk"))))
(build-system gnu-build-system)
;; When cross-compiling, this package needs a source directory of a
;; native-build of itself.