summaryrefslogtreecommitdiff
path: root/gnu/packages/icu4c.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-05 19:50:25 +0000
committerMark H Weaver <mhw@netris.org>2015-01-06 13:35:13 -0500
commit0d93648bece32ba516812b3a4264dd0a72810dbf (patch)
tree66bf15eabd462b7715868dc59a0825c4d0658ac5 /gnu/packages/icu4c.scm
parentcf0a154c4105abf42824007848f4e319ce23f987 (diff)
downloadguix-patches-0d93648bece32ba516812b3a4264dd0a72810dbf.tar
guix-patches-0d93648bece32ba516812b3a4264dd0a72810dbf.tar.gz
gnu: icu4c: Avoid use of 'patchelf'; fix build on ARM systems.
* gnu/packages/icu4c.scm (icu4c)[inputs]: Remove patchelf. [configure-flags]: Add --enable-rpath. Add --with-data-packaging=archive on arm systems. [phases]: Remove 'add-lib-to-runpath' phase.
Diffstat (limited to 'gnu/packages/icu4c.scm')
-rw-r--r--gnu/packages/icu4c.scm31
1 files changed, 9 insertions, 22 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index ea5aecc21f..a575e91c8c 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,7 +19,6 @@
(define-module (gnu packages icu4c)
#:use-module (gnu packages)
- #:use-module (gnu packages elf)
#:use-module (gnu packages perl)
#:use-module (guix licenses)
#:use-module (guix packages)
@@ -40,16 +40,14 @@
(base32 "1cwapgjmvrcv1n2wjspj3vahidg596gjfp4jn1gcb4baralcjayl"))))
(build-system gnu-build-system)
(inputs
- `(("patchelf" ,patchelf)
- ("perl" ,perl)))
+ `(("perl" ,perl)))
(arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build utils)
- (guix build rpath)
- (srfi srfi-26))
- #:imported-modules ((guix build gnu-build-system)
- (guix build utils)
- (guix build rpath))
+ `(#:configure-flags
+ '("--enable-rpath"
+ ,@(if (string-prefix? "arm" (or (%current-target-system)
+ (%current-system)))
+ '("--with-data-packaging=archive")
+ '()))
#:phases
(alist-cons-after
'unpack 'chdir-to-source
@@ -62,18 +60,7 @@
(substitute* "configure"
(("`/bin/sh")
(string-append "`" (which "bash")))))
- (alist-cons-after
- 'strip 'add-lib-to-runpath
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib")))
- ;; Add LIB to the RUNPATH of all the libraries and binaries.
- (with-directory-excursion out
- (for-each (cut augment-rpath <> lib)
- (append (find-files "lib" ".*")
- (find-files "bin" ".*")
- (find-files "sbin" ".*"))))))
- %standard-phases)))))
+ %standard-phases))))
(synopsis "International Components for Unicode")
(description
"ICU is a set of C/C++ and Java libraries providing Unicode and