summaryrefslogtreecommitdiff
path: root/gnu/packages/icu4c.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-18 12:17:01 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-18 12:19:34 +0200
commit048934c3b6afec494e3258f0a57a3031072022b2 (patch)
treedd347ef1f9104f20a47e967d63ca2999cac62cdb /gnu/packages/icu4c.scm
parent68557cd2f3c6ca2ec317acb46dc3225c89178b7f (diff)
downloadguix-patches-048934c3b6afec494e3258f0a57a3031072022b2.tar
guix-patches-048934c3b6afec494e3258f0a57a3031072022b2.tar.gz
gnu: icu4j: Fix build.
* gnu/packages/icu4c.scm (icu4j)[arguments]: Use gexp for 'make-flags'.
Diffstat (limited to 'gnu/packages/icu4c.scm')
-rw-r--r--gnu/packages/icu4c.scm27
1 files changed, 15 insertions, 12 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 0d5f34aed8..b9671a6ab1 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +30,7 @@
#:use-module (gnu packages java)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
+ #:use-module (guix gexp)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -164,18 +166,19 @@ C/C++ part.")
(build-system ant-build-system)
(arguments
`(#:make-flags
- (list (string-append "-Djunit.core.jar="
- (car (find-files
- (assoc-ref %build-inputs "java-junit")
- ".*.jar$")))
- (string-append "-Djunit.junitparams.jar="
- (car (find-files
- (assoc-ref %build-inputs "java-junitparams")
- ".*.jar$")))
- (string-append "-Djunit.hamcrest.jar="
- (car (find-files
- (assoc-ref %build-inputs "java-hamcrest-core")
- ".*.jar$"))))
+ ,#~(list
+ (string-append "-Djunit.core.jar="
+ (car (find-files
+ #$(this-package-native-input "java-junit")
+ ".*.jar$")))
+ (string-append "-Djunit.junitparams.jar="
+ (car (find-files
+ #$(this-package-native-input "java-junitparams")
+ ".*.jar$")))
+ (string-append "-Djunit.hamcrest.jar="
+ (car (find-files
+ #$(this-package-native-input "java-hamcrest-core")
+ ".*.jar$"))))
#:phases
(modify-phases %standard-phases
(add-before 'configure 'chdir