summaryrefslogtreecommitdiff
path: root/gnu/packages/ibus.scm
diff options
context:
space:
mode:
authorkanichos@yandex.ru <kanichos@yandex.ru>2020-01-02 13:52:44 +0300
committerRicardo Wurmus <rekado@elephly.net>2020-01-03 07:20:38 +0100
commit94b8fe80419b835dbcab989a48d272c2bb65798f (patch)
treecf0f885d89c1933959909779e0a369059dab6e9f /gnu/packages/ibus.scm
parent28cdd818faf78d24841a965cf05a85b96fbd7ed5 (diff)
downloadguix-patches-94b8fe80419b835dbcab989a48d272c2bb65798f.tar
guix-patches-94b8fe80419b835dbcab989a48d272c2bb65798f.tar.gz
gnu: Add libhangul.
* gnu/packages/ibus.scm (libhangul): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/ibus.scm')
-rw-r--r--gnu/packages/ibus.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 23cd670920..01d14c8c7a 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Meiyo Peng <meiyo@disroot.org>
+;;; Copyright © 2020 kanichos <kanichos@yandex.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -688,3 +689,23 @@ input methods as well as those for Chinese dialects. It has the ability to
compose phrases and sentences intelligently and provide very accurate
traditional Chinese output.")
(license gpl3+)))
+
+(define-public libhangul
+ (package
+ (name "libhangul")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://kldp.net/hangul/release/"
+ "3442-libhangul-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ni9b0v70wkm0116na7ghv03pgxsfpfszhgyj3hld3bxamfal1ar"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/libhangul/libhangul")
+ (synopsis "Library to support hangul input method logic")
+ (description
+ "This package provides a library to support hangul input method logic,
+hanja dictionary and small hangul character classification.")
+ (license lgpl2.1+)))