summaryrefslogtreecommitdiff
path: root/gnu/packages/ibus.scm
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2016-04-03 16:31:08 -0700
committer宋文武 <iyzsong@gmail.com>2016-04-09 09:36:29 +0800
commit1c6ae41875b8531155e29df2f60851d161cc04b9 (patch)
tree51712ad483519b5946e254aa57bab9cf7c0e6c17 /gnu/packages/ibus.scm
parent4862910d0aeda17d4f5816d9681dad93255cf039 (diff)
downloadguix-patches-1c6ae41875b8531155e29df2f60851d161cc04b9.tar
guix-patches-1c6ae41875b8531155e29df2f60851d161cc04b9.tar.gz
gnu: Add ibus-anthy.
* gnu/packages/ibus.scm (ibus-anthy): New variable. Co-authored-by: 宋文武 <iyzsong@gmail.com>.
Diffstat (limited to 'gnu/packages/ibus.scm')
-rw-r--r--gnu/packages/ibus.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 770d7ff067..db7d084fc7 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,10 +25,12 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
+ #:use-module (gnu packages anthy)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages databases)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
@@ -205,3 +208,54 @@ ZhuYin (Bopomofo) input method based on libpinyin for IBus.")
Chinese pinyin input methods.")
(home-page "https://github.com/libpinyin/libpinyin")
(license gpl2+)))
+
+(define-public ibus-anthy
+ (package
+ (name "ibus-anthy")
+ (version "1.5.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/ibus/ibus-anthy/releases/download/"
+ version "/ibus-anthy-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1aj7vnfky7izl23xyjky78z3qas3q72l3kr8dnql2lnivsrb8q1y"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ ;; Use absolute exec path in the anthy.xml.
+ (list (string-append "--libexecdir=" %output "/libexec"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-programs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each
+ (lambda (prog)
+ (wrap-program (string-append out "/libexec/" prog)
+ `("PYTHONPATH" ":" prefix
+ (,(getenv "PYTHONPATH")))
+ `("GI_TYPELIB_PATH" ":" prefix
+ (,(getenv "GI_TYPELIB_PATH")
+ ,(string-append out "/lib/girepository-1.0")))))
+ '("ibus-engine-anthy" "ibus-setup-anthy"))
+ #t))))))
+ (native-inputs
+ `(("gettext" ,gnu-gettext)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (inputs
+ `(("anthy" ,anthy)
+ ("gtk+" ,gtk+)
+ ("ibus" ,ibus)
+ ("gobject-introspection" ,gobject-introspection)
+ ("python-pygobject" ,python-pygobject)))
+ (synopsis "Anthy Japanese language input method for IBus")
+ (description "IBus-Anthy is an engine for the input bus \"IBus\"). It
+adds the Anthy Japanese language input method to IBus. Because most graphical
+applications allow text input via IBus, installing this package will enable
+Japanese language input in most graphical applications.")
+ (home-page "https://github.com/fujiwarat/ibus-anthy")
+ (license gpl2+)))