summaryrefslogtreecommitdiff
path: root/gnu/packages/i2p.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-25 09:00:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-25 09:07:49 +0300
commite52c64cb04f1cf52611b2f8fd2660675a6829db4 (patch)
treef4973c240c18433a5c1359eeb4d901177bdae1c0 /gnu/packages/i2p.scm
parente47b7a73becbee8b513a65b76337438d4909b449 (diff)
downloadguix-patches-e52c64cb04f1cf52611b2f8fd2660675a6829db4.tar
guix-patches-e52c64cb04f1cf52611b2f8fd2660675a6829db4.tar.gz
gnu: i2pd: Reflow package definition.
* gnu/packages/i2p.scm (i2pd): Reflow package definition.
Diffstat (limited to 'gnu/packages/i2p.scm')
-rw-r--r--gnu/packages/i2p.scm66
1 files changed, 34 insertions, 32 deletions
diff --git a/gnu/packages/i2p.scm b/gnu/packages/i2p.scm
index 7b9b1e13ee..4da58087e7 100644
--- a/gnu/packages/i2p.scm
+++ b/gnu/packages/i2p.scm
@@ -42,38 +42,40 @@
(sha256
(base32 "1a35grcfw5a9dsj0rnm2i86fjf4px96xbnjj3hkril7hv5jvl37k"))))
(build-system cmake-build-system)
- (inputs `(("boost" ,boost)
- ("miniupnpc" ,miniupnpc)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
- (arguments '(#:configure-flags
- (let ((source (assoc-ref %build-inputs "source")))
- (list (string-append "-S" source "/build")
- "-DWITH_PCH=OFF"
- "-DWITH_STATIC=OFF"
- "-DWITH_UPNP=ON"
- "-DWITH_LIBRARY=ON"
- "-DBUILD_SHARED_LIBS=ON"
- "-DWITH_BINARY=ON"))
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key
- (make-flags '())
- (parallel-tests? #t)
- #:allow-other-keys)
- (let ((source (assoc-ref %build-inputs "source")))
- (copy-recursively (string-append source "/tests")
- "./tests")
- (with-directory-excursion "tests"
- (substitute* "Makefile"
- (("../libi2pd/") (string-append source "/libi2pd/")))
- (apply invoke "make" "all"
- `(,@(if parallel-tests?
- `("-j" ,(number->string
- (parallel-job-count)))
- '())
- ,@make-flags)))))))))
+ (inputs
+ `(("boost" ,boost)
+ ("miniupnpc" ,miniupnpc)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (arguments
+ '(#:configure-flags
+ (let ((source (assoc-ref %build-inputs "source")))
+ (list (string-append "-S" source "/build")
+ "-DWITH_PCH=OFF"
+ "-DWITH_STATIC=OFF"
+ "-DWITH_UPNP=ON"
+ "-DWITH_LIBRARY=ON"
+ "-DBUILD_SHARED_LIBS=ON"
+ "-DWITH_BINARY=ON"))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key
+ (make-flags '())
+ (parallel-tests? #t)
+ #:allow-other-keys)
+ (let ((source (assoc-ref %build-inputs "source")))
+ (copy-recursively (string-append source "/tests")
+ "./tests")
+ (with-directory-excursion "tests"
+ (substitute* "Makefile"
+ (("../libi2pd/") (string-append source "/libi2pd/")))
+ (apply invoke "make" "all"
+ `(,@(if parallel-tests?
+ `("-j" ,(number->string
+ (parallel-job-count)))
+ '())
+ ,@make-flags)))))))))
(home-page "https://i2pd.website/")
(synopsis "Router for an end-to-end encrypted and anonymous internet")
(description "i2pd is a client for the anonymous I2P network, upon which