summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2014-03-01 14:48:09 +0000
committerLudovic Courtès <ludo@gnu.org>2014-03-01 18:59:34 +0100
commitdc91c10f2bc21982f26a9f90721f23b79b5668b7 (patch)
treedaf2ba19e2f7ee4d8f1148d000a36fb03090a490 /gnu/packages/hurd.scm
parentdd67b429e1644407a928a8c12ab7649bf9c50145 (diff)
downloadguix-patches-dc91c10f2bc21982f26a9f90721f23b79b5668b7.tar
guix-patches-dc91c10f2bc21982f26a9f90721f23b79b5668b7.tar.gz
gnu: hurd: Add Hurd headers.
* gnu/packages/hurd.scm (hurd-headers): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm44
1 files changed, 43 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 3edccbdd1c..f1e7dbc9dc 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -22,7 +22,9 @@
#:use-module (guix packages)
#:use-module (guix build-system gnu)
#:use-module (gnu packages flex)
- #:use-module (gnu packages bison))
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages autotools))
(define-public gnumach-headers
(package
@@ -86,3 +88,43 @@ and to compile the GNU C library for the Hurd. Also,you will need it
for other software in the GNU system that uses Mach-based inter-process
communication.")
(license gpl2+)))
+
+(define-public hurd-headers
+ (package
+ (name "hurd-headers")
+ (version "0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/hurd/hurd-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0lvkz3r0ngb4bsn2hzdc9vjpyrfa3ls36jivrvy1n7f7f55zan7q"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(;; Autoconf shouldn't be necessary but there seems to be a bug in the
+ ;; build system triggering its use.
+ ("autoconf" ,autoconf)
+
+ ("mig" ,mig)))
+ (arguments
+ `(#:phases (alist-replace
+ 'install
+ (lambda _
+ (zero? (system* "make" "install-headers" "no_deps=t")))
+ (alist-delete 'build %standard-phases))
+
+ #:configure-flags '(;; Pretend we're on GNU/Hurd; 'configure' wants
+ ;; that.
+ "--host=i686-pc-gnu"
+
+ ;; Reduce set of dependencies.
+ "--without-parted")
+
+ #:tests? #f))
+ (home-page "http://www.gnu.org/software/hurd/hurd.html")
+ (synopsis "GNU Hurd headers")
+ (description
+ "This package provides C headers of the GNU Hurd, used to build the GNU C
+Library and other user programs.")
+ (license gpl2+)))