summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2017-03-16 09:29:55 -0600
committerLudovic Courtès <ludo@gnu.org>2017-03-19 18:14:22 +0100
commit8df672aad5dc8d93da750c96f472ba2155d51da1 (patch)
treef617f6b24d4c56fb3c55ec23e5a7839dc3d2ebed /gnu/packages/hurd.scm
parentf729a4d8b274aebd578f45b2ca55cded31001b85 (diff)
downloadguix-patches-8df672aad5dc8d93da750c96f472ba2155d51da1.tar
guix-patches-8df672aad5dc8d93da750c96f472ba2155d51da1.tar.gz
gnu: Add GNU Mach.
* gnu/packages/hurd.scm (gnumach): New variable. Co-authored-by: Rene Saavedra <rennes@openmailbox.org> Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index ba91b60bea..2d7b7b2ac0 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
+;;; Copyright © 2014, 2015, 2016, 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -210,3 +210,35 @@ Library for GNU/Hurd.")
Hurd-minimal package which are needed for both glibc and GCC.")
(home-page (package-home-page hurd-headers))
(license (package-license hurd-headers))))
+
+(define-public gnumach
+ (package
+ (name "gnumach")
+ (version "1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (gnumach-source-url version))
+ (sha256
+ (base32
+ "02hygsfpd2dljl5lg1vjjg9pizi9jyxd4aiiqzjshz6jax62jm9f"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'install 'produce-image
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (boot (string-append out "/boot")))
+ (and (zero? (system* "make" "gnumach.gz"))
+ (begin
+ (install-file "gnumach.gz" boot)
+ #t))))))))
+ (native-inputs
+ `(("mig" ,mig)
+ ("perl" ,perl)))
+ (supported-systems (cons "i686-linux" %hurd-systems))
+ (home-page
+ "https://www.gnu.org/software/hurd/microkernel/mach/gnumach.html")
+ (synopsis "Microkernel of the GNU system")
+ (description
+ "GNU Mach is the microkernel upon which a GNU Hurd system is based.")
+ (license gpl2+)))