summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-10-10 22:26:14 +0200
committerLudovic Courtès <ludo@gnu.org>2020-10-10 22:37:45 +0200
commit6530f5367c1ba0ef4de59d865c0aaa184f868f5a (patch)
tree492bbcd74d6ee1b2c697ca384debcf814a3cdc4c /gnu/packages/hurd.scm
parentb55409b2c0a0cb53f251ceab7746d35805b64ab7 (diff)
downloadguix-patches-6530f5367c1ba0ef4de59d865c0aaa184f868f5a.tar
guix-patches-6530f5367c1ba0ef4de59d865c0aaa184f868f5a.tar.gz
gnu: mig: Define 'mig/32-bit'.
* gnu/packages/hurd.scm (mig/32-bit): New variable. (hurd)[native-inputs]: Use it. Previous inline variant would drop the 'patch-non-shebang-references' phase.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 98fe594b7f..47c7e17573 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -157,6 +157,17 @@ for other software in the GNU system that uses Mach-based inter-process
communication.")
(license gpl2+)))
+(define-public mig/32-bit
+ ;; When cross-compiling from x86_64-linux to i586-gnu, we need this 32-bit
+ ;; native MIG.
+ (package
+ (inherit mig)
+ (arguments
+ (substitute-keyword-arguments (package-arguments mig)
+ ((#:system _ #f)
+ "i686-linux")))
+ (properties `((hidden? . #t)))))
+
(define-public hurd-headers
;; Resort to a post-0.9 snapshot that provides the 'file_utimens' and
;; 'file_exec_paths' RPCs that glibc 2.28 expects.
@@ -536,9 +547,7 @@ exec ${system}/rc \"$@\"
("mig" ,(if (%current-target-system)
;; XXX: When targeting i586-pc-gnu, we need a 32-bit MiG,
;; hence this hack.
- (package
- (inherit mig)
- (arguments `(#:system "i686-linux")))
+ mig/32-bit
mig))
("perl" ,perl)
("texinfo" ,texinfo-4)