summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2016-05-24 20:42:59 +0300
committerManolis Ragkousis <manolis837@gmail.com>2016-05-26 14:41:56 +0300
commit38efbcbb7929b2cfb12efae60acc2bfb8bb2c988 (patch)
tree1bbface043cbaa90cc74309e68b9fcd60e6b8859 /gnu/packages/hurd.scm
parent4791876ce15fd4dd78c6688059fc6de7b61eee02 (diff)
downloadguix-patches-38efbcbb7929b2cfb12efae60acc2bfb8bb2c988.tar
guix-patches-38efbcbb7929b2cfb12efae60acc2bfb8bb2c988.tar.gz
gnu: hurd: Add hurd-core-headers package.
* gnu/packages/hurd.scm (hurd-core-headers): New variable.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 7a0a158899..2b2e162107 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
+;;; Copyright © 2014, 2015, 2016 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +22,7 @@
#:use-module (guix packages)
#:use-module (gnu packages)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages flex)
#:use-module (gnu packages bison)
#:use-module (gnu packages perl)
@@ -185,3 +186,28 @@ Library and other user programs.")
"This package provides libihash, needed to build the GNU C
Library for GNU/Hurd.")
(license gpl2+)))
+
+(define-public hurd-core-headers
+ (package
+ (name "hurd-core-headers")
+ (version (package-version hurd-headers))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build union))
+ #:builder (begin
+ (use-modules (ice-9 match)
+ (guix build union))
+ (match %build-inputs
+ (((names . directories) ...)
+ (union-build (assoc-ref %outputs "out")
+ directories))))))
+ (inputs `(("gnumach-headers" ,gnumach-headers)
+ ("hurd-headers" ,hurd-headers)
+ ("hurd-minimal" ,hurd-minimal)))
+ (synopsis "Union of the Hurd headers and libraries")
+ (description
+ "This package contains the union of the Mach and Hurd headers and the
+Hurd-minimal package which are needed for both glibc and GCC.")
+ (home-page (package-home-page hurd-headers))
+ (license (package-license hurd-headers))))